summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-25 09:28:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-25 09:34:55 +0200
commit39c954d1d92e26cb03cd0afb0fd90f3b59f53aa7 (patch)
tree4b1c34a41a255639002bb9ccac4a92e6421a2cc6
parentda92bca5bd5cd2da82f66079ab411af201ba8c1b (diff)
gnu: clang-runtime-14: Fix build with newer glibc.
* gnu/packages/llvm.scm (%llvm-patches): Add patch for llvm-14. * gnu/packages/patches/clang-runtime-14-glibc-2.36-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: Ib5350be48f6580d00cb9b70435931abf0444c664
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/llvm.scm3
-rw-r--r--gnu/packages/patches/clang-runtime-14-glibc-2.36-compat.patch50
3 files changed, 53 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 96bd5277ea..5f54a4520c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1029,6 +1029,7 @@ dist_patch_DATA = \
%D%/packages/patches/clang-17.0-libc-search-path.patch \
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
+ %D%/packages/patches/clang-runtime-14-glibc-2.36-compat.patch \
%D%/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch \
%D%/packages/patches/clang-runtime-3.5-libsanitizer-mode-field.patch \
%D%/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch \
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 1635525185..56db3ad82e 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -597,7 +597,8 @@ output), and Binutils.")
("17.0.6" . "1a7rq3rgw5vxm8y39fyzr4kv7w97lli4a0c1qrkchwk8p0n07hgh")))
(define %llvm-patches
- '(("14.0.6" . ("clang-14.0-libc-search-path.patch"))
+ '(("14.0.6" . ("clang-14.0-libc-search-path.patch"
+ "clang-runtime-14-glibc-2.36-compat.patch"))
("15.0.7" . ("clang-15.0-libc-search-path.patch"))
("16.0.6" . ("clang-16.0-libc-search-path.patch"))
("17.0.6" . ("clang-17.0-libc-search-path.patch"))))
diff --git a/gnu/packages/patches/clang-runtime-14-glibc-2.36-compat.patch b/gnu/packages/patches/clang-runtime-14-glibc-2.36-compat.patch
new file mode 100644
index 0000000000..79b36f1383
--- /dev/null
+++ b/gnu/packages/patches/clang-runtime-14-glibc-2.36-compat.patch
@@ -0,0 +1,50 @@
+This commit is from upstream and is included in the llvm-15 release
+
+commit b379129c4beb3f26223288627a1291739f33af02
+Author: Fangrui Song <i@maskray.me>
+Date: Mon Jul 11 11:38:28 2022 -0700
+
+ [sanitizer] Remove #include <linux/fs.h> to resolve fsconfig_command/mount_attr conflict with glibc 2.36
+
+ It is generally not a good idea to mix usage of glibc headers and Linux UAPI
+ headers (https://sourceware.org/glibc/wiki/Synchronizing_Headers). In glibc
+ since 7eae6a91e9b1670330c9f15730082c91c0b1d570 (milestone: 2.36), sys/mount.h
+ defines `fsconfig_command` which conflicts with linux/mount.h:
+
+ .../usr/include/linux/mount.h:95:6: error: redeclaration of ‘enum fsconfig_command’
+
+ Remove #include <linux/fs.h> which pulls in linux/mount.h. Expand its 4 macros manually.
+
+ Fix https://github.com/llvm/llvm-project/issues/56421
+
+ Reviewed By: #sanitizers, vitalybuka, zatrazz
+
+ Differential Revision: https://reviews.llvm.org/D129471
+
+diff --git a/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp b/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
+index 4bd425435d56..81740bf4ab39 100644
+--- a/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
++++ b/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
+@@ -73,7 +73,6 @@
+ #include <sys/vt.h>
+ #include <linux/cdrom.h>
+ #include <linux/fd.h>
+-#include <linux/fs.h>
+ #include <linux/hdreg.h>
+ #include <linux/input.h>
+ #include <linux/ioctl.h>
+@@ -876,10 +875,10 @@ unsigned struct_ElfW_Phdr_sz = sizeof(Elf_Phdr);
+ unsigned IOCTL_EVIOCGPROP = IOCTL_NOT_PRESENT;
+ unsigned IOCTL_EVIOCSKEYCODE_V2 = IOCTL_NOT_PRESENT;
+ #endif
+- unsigned IOCTL_FS_IOC_GETFLAGS = FS_IOC_GETFLAGS;
+- unsigned IOCTL_FS_IOC_GETVERSION = FS_IOC_GETVERSION;
+- unsigned IOCTL_FS_IOC_SETFLAGS = FS_IOC_SETFLAGS;
+- unsigned IOCTL_FS_IOC_SETVERSION = FS_IOC_SETVERSION;
++ unsigned IOCTL_FS_IOC_GETFLAGS = _IOR('f', 1, long);
++ unsigned IOCTL_FS_IOC_GETVERSION = _IOR('v', 1, long);
++ unsigned IOCTL_FS_IOC_SETFLAGS = _IOW('f', 2, long);
++ unsigned IOCTL_FS_IOC_SETVERSION = _IOW('v', 2, long);
+ unsigned IOCTL_GIO_CMAP = GIO_CMAP;
+ unsigned IOCTL_GIO_FONT = GIO_FONT;
+ unsigned IOCTL_GIO_UNIMAP = GIO_UNIMAP;