summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-02-11 19:38:16 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 13:14:20 -0500
commit3f4176ec376c2d07daaa2eabbcf613d6ff94219d (patch)
treec2aa42d079ee8ca514fb2539de6838380a57025c
parent8219ab0443129c71eef83ee4bd3aae0a0a12b6f9 (diff)
gnu: findutils-boot0: Re-enable most tests.
* gnu/packages/commencement.scm (findutils-boot0) [arguments]: Enable tests. Rename skip-fnmatch-test phase skip-problematic-tests. Only disable test-fnmatch on x86_64 and i686. Disable pthread tests on other platforms. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I1efd62d98a27c3d9b878f37c890d6ff0ea6ea675
-rw-r--r--gnu/packages/commencement.scm33
1 files changed, 19 insertions, 14 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c88f86d40f..d2c1565e20 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2022, 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
@@ -2015,10 +2016,7 @@ exec " gcc "/bin/" program
,@(%bootstrap-inputs+toolchain)))
(arguments
`(#:implicit-inputs? #f
- ;; Ignore test failure in gnulib for armhf/aarch64.
- #:tests? ,(not (target-arm?))
#:guile ,%bootstrap-guile
-
;; The build system assumes we have done a mistake when time_t is 32-bit
;; on a 64-bit system. Ignore that for our bootstrap toolchain.
,@(substitute-keyword-arguments (package-arguments findutils)
@@ -2035,17 +2033,24 @@ exec " gcc "/bin/" program
,flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
- ;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
- ;; to incorrect handling of the [:alpha:] regexp character
- ;; class. Ignore it.
- ,@(if (member (%current-system)
- '("x86_64-linux" "i686-linux"))
- '((add-before 'check 'skip-fnmatch-test
- (lambda _
- (substitute* "gnulib-tests/Makefile"
- (("^XFAIL_TESTS =")
- "XFAIL_TESTS = test-fnmatch ")))))
- '()))))))))
+ (add-before 'check 'skip-problematic-tests
+ (lambda _
+ ,(match (%current-system)
+ ;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
+ ;; to incorrect handling of the [:alpha:] regexp character
+ ;; class. Ignore it.
+ ((or "x86_64-linux" "i686-linux")
+ '(substitute* "gnulib-tests/Makefile"
+ (("^XFAIL_TESTS =")
+ "XFAIL_TESTS = test-fnmatch ")))
+ (_
+ ;; XXX: The pthread tests are known to fail at least on
+ ;; ARM; skip them.
+ '(substitute* "gnulib-tests/Makefile"
+ (("test-pthread\\$\\(EXEEXT\\)") "")
+ (("test-pthread-thread\\$\\(EXEEXT\\)") "")
+ (("test-pthread_sigmask1\\$\\(EXEEXT\\)") "")
+ (("test-pthread_sigmask2\\$\\(EXEEXT\\)") "")))))))))))))
(define file
(package