summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-24 17:13:23 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-24 17:16:12 +0100
commit641f252fdbc0baa6bded5b65f23a7ef187fbb1ae (patch)
treebdb30cc3f96cdf0d41860e21ce3758c133d492c9
parent2616dbbe8dfcd76b5b8b1cae2da09341ec3f6fb1 (diff)
gnu: python-pyelftools: Update to 0.30 [fixes build].
This avoids Test file 'test/testfiles_for_readelf/aarch64-relocs-le.o.elf' .......................FAIL ....for file test/testfiles_for_readelf/aarch64-relocs-le.o.elf ....for option "--debug-dump=info" ....Output #1 is readelf, Output #2 is pyelftools @@ Mismatch on line #1: >> compilation unit @ offset 0:<< >> compilation unit @ offset 0x0:<< ([('equal', 0, 29, 0, 29), ('insert', 29, 29, 29, 31), ('equal', 29, 30, 31, 32)]) * gnu/packages/python-xyz.scm (python-pyelftools): Update to 0.30. [description]: Remove gratuitous whitespace. Change-Id: I6e15e4532affd7faa7272d42adb65a2efcccce46
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e984b471fb..e041108eb7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -143,7 +143,7 @@
;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © c4droid <c4droid@foxmail.com>
-;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
;;;
@@ -21847,7 +21847,7 @@ OpenSSH Server for example.")
(define-public python-pyelftools
(package
(name "python-pyelftools")
- (version "0.29")
+ (version "0.30")
(home-page "https://github.com/eliben/pyelftools")
(source
(origin
@@ -21856,7 +21856,7 @@ OpenSSH Server for example.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mi7i9zlhkkap4q50ciak57ia46mj2jzq0713m3dh0x8j05k9xml"))
+ (base32 "0gk47mq5cqv6qz35aydn67wma5m70gv5f9f6pg38zny6vsfavmq3"))
(snippet
;; Delete bundled readelf executable.
'(delete-file "test/external_tools/readelf"))))
@@ -21873,9 +21873,9 @@ OpenSSH Server for example.")
(synopsis
"Analyze binary and library file information")
(description "This Python library provides interfaces for parsing and
- analyzing two binary and library file formats ; the Executable and Linking
- Format (ELF), and debugging information in the Debugging With Attributed
- Record Format (DWARF).")
+analyzing two binary and library file formats ; the Executable and Linking
+Format (ELF), and debugging information in the Debugging With Attributed
+Record Format (DWARF).")
(license license:public-domain)))
(define-public python-pefile