summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-30 18:02:38 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-25 22:39:24 +0100
commit6b34e08e4d257b31d21404405b66b730f15a0b89 (patch)
tree5efe4855d3935e3e906a47714af2778aa4ea16ee
parentddba840eddba7200d5df60e7f3783fc37d7d7a53 (diff)
DRAFT hurd: Support second boot.
XXX This works beautifully, also on my x60, as long as the filesystem is clean. Although our fsck in libexec/runsystem doesn't work without or with the current ftab, this may be a bad idea? This avoids hanging upon second boot and ensures a declarative /hurd and /dev. * gnu/packages/patches/hurd-startup.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/hurd.scm (hurd): Use it. [arguments]: In stage create-runsystem remove /dev/urandom.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/hurd.scm6
-rw-r--r--gnu/packages/patches/hurd-startup.patch82
3 files changed, 88 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8170ba6b83..9761325cb3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1458,6 +1458,7 @@ dist_patch_DATA = \
%D%/packages/patches/hurd-add-without-rump-configure-option.patch \
%D%/packages/patches/hurd-fix-rumpdisk-build.patch \
%D%/packages/patches/hurd-rumpdisk-no-hd.patch \
+ %D%/packages/patches/hurd-startup.patch \
%D%/packages/patches/hurd-fix-types-of-read-write-and-readables-methods-2.patch \
%D%/packages/patches/hurd-fix-types-of-read-write-and-readables-methods.patch \
%D%/packages/patches/hwloc-1-test-btrfs.patch \
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index fbd8bd1b2b..f1d76f8695 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -323,7 +323,8 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(source (origin
(inherit (package-source hurd-headers))
(patches (search-patches "hurd-fix-rumpdisk-build.patch"
- "hurd-rumpdisk-no-hd.patch"))))
+ "hurd-rumpdisk-no-hd.patch"
+ "hurd-startup.patch"))))
(version (package-version hurd-headers))
(arguments
`(#:tests? #f ;no "check" target
@@ -394,6 +395,9 @@ rm -f /servers/socket/1
# Note: this /hurd/ gets substituted
settrans --create /servers/socket/1 /hurd/pflocal
+# Upon second boot, (file-exists? /dev/null) in hurd-boot-system hangs unless:
+rm -f /dev/urandom
+
# parse multiboot arguments
for i in \"$@\"; do
case $i in
diff --git a/gnu/packages/patches/hurd-startup.patch b/gnu/packages/patches/hurd-startup.patch
new file mode 100644
index 0000000000..0b0dcc9537
--- /dev/null
+++ b/gnu/packages/patches/hurd-startup.patch
@@ -0,0 +1,82 @@
+This avoids hanging upon second boot and ensures a declarative /dev.
+
+Upstream status: Not presented upstream.
+
+From a15d281ea012ee360c45376e964d35f6292ac549 Mon Sep 17 00:00:00 2001
+From: Janneke Nieuwenhuizen <janneke@gnu.org>
+Date: Sat, 27 May 2023 17:28:22 +0200
+Subject: [PATCH] startup: Remove /hurd, /dev, create /servers.
+
+This avoids hanging upon second boot and ensures a declarative /hurd
+and /dev.
+
+* startup/startup.c (rm_r, create_servers): New functions.
+(main): Use them to remove /dev and create /servers. Remove /hurd
+symlink.
+---
+ startup/startup.c | 42 ++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 42 insertions(+)
+
+diff --git a/startup/startup.c b/startup/startup.c
+index feb7d265..5f380194 100644
+--- a/startup/startup.c
++++ b/startup/startup.c
+@@ -732,6 +732,42 @@ parse_opt (int key, char *arg, struct argp_state *state)
+ return 0;
+ }
+
++#include <ftw.h>
++static int
++rm_r (char const *file_name)
++{
++ int callback (char const *file_name, struct stat64 const *stat_buffer,
++ int type_flag, struct FTW *ftw_buffer)
++ {
++ fprintf (stderr, "startup: removing: %s\n", file_name);
++ return remove (file_name);
++ }
++
++ return nftw64 (file_name, callback, 0, FTW_DEPTH | FTW_MOUNT | FTW_PHYS);
++}
++
++void
++create_servers (void)
++{
++ char const *servers[] = {
++ "/servers/startup",
++ "/servers/exec",
++ "/servers/proc",
++ "/servers/password",
++ "/servers/default-pager",
++ "/servers/crash-dump-core",
++ "/servers/kill",
++ "/servers/suspend",
++ 0,
++ };
++ mkdir ("/servers", 0755);
++ for (char const **p = servers; *p; p++)
++ open (*p, O_WRONLY | O_APPEND | O_CREAT, 0444);
++ mkdir ("/servers/socket", 0755);
++ mkdir ("/servers/bus", 0755);
++ mkdir ("/servers/bus/pci", 0755);
++}
++
+ int
+ main (int argc, char **argv, char **envp)
+ {
+@@ -741,6 +777,12 @@ main (int argc, char **argv, char **envp)
+ mach_port_t consdev;
+ struct argp argp = { options, parse_opt, 0, doc };
+
++ /* GNU Guix creates fresh ones in boot-hurd-system. */
++ unlink ("/hurd");
++ rm_r ("/dev");
++ mkdir ("/dev", 0755);
++ create_servers ();
++
+ /* Parse the arguments. We don't want the vector reordered, we
+ should pass on to our child the exact arguments we got and just
+ ignore any arguments that aren't flags for us. ARGP_NO_ERRS
+--
+2.40.1
+