summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 16:02:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-24 19:21:14 +0200
commitd8f6ee66df520c51722a8f755136a213309cb2e7 (patch)
treebeae6c58165dfc1c22236684f29cdc902155a9c9
parent91b337be15a707e88cb287fc6247cd5d09b48656 (diff)
gnu: range-v3: Format with 'guix style'.
* gnu/packages/cpp.scm (range-v3): Format with 'guix style'. Change-Id: I249443e5e5d0f7ef49e33de4f140246a862101d2
-rw-r--r--gnu/packages/cpp.scm43
1 files changed, 19 insertions, 24 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ed5cf429fb..132d438619 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -191,41 +191,36 @@ development effort.")
(source
(origin
(method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/ericniebler/range-v3.git")
- (commit version)))
- (file-name
- (git-file-name name version))
+ (uri (git-reference
+ (url "https://github.com/ericniebler/range-v3.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(patches (search-patches "range-v3-build-with-gcc10.patch"))
(sha256
(base32 "18230bg4rq9pmm5f8f65j444jpq56rld4fhmpham8q3vr1c1bdjh"))))
(build-system cmake-build-system)
(arguments
(list
- #:configure-flags
- #~(list "-DRANGES_NATIVE=OFF")))
- (native-inputs
- (list doxygen perl))
- (inputs
- (list boost))
+ #:configure-flags #~(list "-DRANGES_NATIVE=OFF")))
+ (native-inputs (list doxygen perl))
+ (inputs (list boost))
(synopsis "Range library for C++14/17/20")
- (description "Range-v3 is an extension of the Standard Template Library that
+ (description
+ "Range-v3 is an extension of the Standard Template Library that
makes its iterators and algorithms more powerful by making them composable.
Unlike other range-like solutions which, seek to do away with iterators, in
range-v3 ranges are an abstraction layer on top of iterators.")
(home-page "https://github.com/ericniebler/range-v3/")
- (license
- (list
- ;; Elements of Programming
- (license:x11-style "file:///LICENSE.txt")
- ;; SGI STL
- license:sgifreeb2.0
-;;; LibC++ (dual-licensed)
- license:expat
- license:ncsa
- ;; Others
- license:boost1.0))))
+ (license (list
+ ;; Elements of Programming
+ (license:x11-style "file:///LICENSE.txt")
+ ;; SGI STL
+ license:sgifreeb2.0
+ ;; LibC++ (dual-licensed)
+ license:expat
+ license:ncsa
+ ;; Others
+ license:boost1.0))))
(define-public robin-hood-hashing
(package