summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLilah Tascheter <lilah@lunabee.space>2022-10-19 10:27:57 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 13:14:19 -0500
commite118e90b591f390c8fffddd973fc2d2996794a07 (patch)
treeec5f4a9d9c9f924a32eaeef505b25db3828235f8
parent30926fc755b679b7297008f4b91975189babce30 (diff)
gnu: man-pages-posix: Remove redundant manpage compression.
* gnu/packages/man.scm (man-pages-posix)[arguments]: Don't run build phase. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/man.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 71fcf2f4bc..1c5ba81be4 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -329,11 +329,11 @@ Linux kernel and C library interfaces employed by user-space programs.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f
- ;; The compress-documentation phase doesn't pick up on our manpages as
- ;; its regex doesn't support trailing letters, so manually compress.
- #:make-flags ,#~(list (string-append "prefix=" #$output) "gz")
+ #:make-flags ,#~(list (string-append "prefix=" #$output))
#:license-file-regexp "POSIX-COPYRIGHT"
- #:phases (modify-phases %standard-phases (delete 'configure))))
+ ;; The build phase only compresses documentation, which we already do.
+ #:phases (modify-phases %standard-phases (delete 'configure)
+ (delete 'build))))
(home-page "https://www.kernel.org/doc/man-pages/")
(synopsis "Man pages from the POSIX.1-2013 standard")
(description