summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 16:19:22 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:33 +0100
commit048b232c51058ccaf29fc029897351757fb4cd9d (patch)
treef448e0121544394a4cac54296a430d2f9c9ce094
parent0f9fe721be2bd36e52b520782b585ca49aa1447d (diff)
gnu: aoflagger: Sort alphabetically.
* gnu/packages/astronomy.scm (aoflagger): Sort alphabetically. Change-Id: Iad26b13f00cc07c4c1bb779acc495ddfe4f68b82
-rw-r--r--gnu/packages/astronomy.scm122
1 files changed, 61 insertions, 61 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c1fe5b0a47..a5263afcbe 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -188,6 +188,67 @@ reused in several astronomical applications, such as @code{wsclean},
@code{aoflagger}, @code{DP3} and @code{everybeam}.")
(license license:gpl3+))))
+(define-public aoflagger
+ (package
+ (name "aoflagger")
+ (version "3.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/aroffringa/aoflagger")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0dxmcy04cayhs4s2z41wls1dnmg9hkffvlqcmc660idqziffvv1g"))
+ (patches
+ (search-patches "aoflagger-use-system-provided-pybind11.patch"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ ;; Tests require external files download from
+ ;; https://www.astron.nl/citt/ci_data/aoflagger/
+ #:tests? #f
+ #:configure-flags
+ #~(list (string-append "-DCASACORE_ROOT_DIR="
+ #$(this-package-input "casacore")))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; aocommon and pybind11 are expected to be found as git submodules,
+ ;; link them before build.
+ (add-after 'unpack 'link-submodule-package
+ (lambda _
+ (rmdir "external/aocommon")
+ (symlink #$(this-package-native-input "aocommon")
+ (string-append (getcwd) "/external/aocommon")))))))
+ (native-inputs
+ (list aocommon
+ boost
+ pkg-config
+ python
+ pybind11))
+ (inputs
+ (list casacore
+ cfitsio
+ fftw
+ gsl
+ gtkmm-3
+ hdf5
+ libpng
+ libsigc++
+ libxml2
+ lua
+ openblas
+ zlib))
+ (home-page "https://gitlab.com/aroffringa/aoflagger")
+ (synopsis "Astronomical tool that can find and remove radio-frequency interference")
+ (description
+ "AOFlagger is a tool that can find and remove radio-frequency
+interference (RFI) in radio astronomical observations. It can make use of Lua
+scripts to make flagging strategies flexible, and the tools are applicable to a
+wide set of telescopes.")
+ (license license:gpl3+)))
+
(define-public calceph
(package
(name "calceph")
@@ -281,67 +342,6 @@ rendering of the atmosphere model and examine its properties.
(replace "qtbase" qtbase-5)))
(synopsis "Qt5 build for the CalcMySky library.")))
-(define-public aoflagger
- (package
- (name "aoflagger")
- (version "3.4.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/aroffringa/aoflagger")
- (commit (string-append "v" version))))
- (sha256
- (base32 "0dxmcy04cayhs4s2z41wls1dnmg9hkffvlqcmc660idqziffvv1g"))
- (patches
- (search-patches "aoflagger-use-system-provided-pybind11.patch"))
- (file-name (git-file-name name version))))
- (build-system cmake-build-system)
- (arguments
- (list
- ;; Tests require external files download from
- ;; https://www.astron.nl/citt/ci_data/aoflagger/
- #:tests? #f
- #:configure-flags
- #~(list (string-append "-DCASACORE_ROOT_DIR="
- #$(this-package-input "casacore")))
- #:phases
- #~(modify-phases %standard-phases
- ;; aocommon and pybind11 are expected to be found as git submodules,
- ;; link them before build.
- (add-after 'unpack 'link-submodule-package
- (lambda _
- (rmdir "external/aocommon")
- (symlink #$(this-package-native-input "aocommon")
- (string-append (getcwd) "/external/aocommon")))))))
- (native-inputs
- (list aocommon
- boost
- pkg-config
- python
- pybind11))
- (inputs
- (list casacore
- cfitsio
- fftw
- gsl
- gtkmm-3
- hdf5
- libpng
- libsigc++
- libxml2
- lua
- openblas
- zlib))
- (home-page "https://gitlab.com/aroffringa/aoflagger")
- (synopsis "Astronomical tool that can find and remove radio-frequency interference")
- (description
- "AOFlagger is a tool that can find and remove radio-frequency
-interference (RFI) in radio astronomical observations. It can make use of Lua
-scripts to make flagging strategies flexible, and the tools are applicable to a
-wide set of telescopes.")
- (license license:gpl3+)))
-
(define-public casacore
(package
(name "casacore")