summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:29:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:35 +0100
commit0836b1b142625b91ea28795711e21d3c4cd6f3a8 (patch)
tree2798ba6bd3b902c25d84fedabbfb1a2d99bef338
parent06480b406bf47161b913107eeb9e09f71253a14e (diff)
gnu: psfex: Sort alphabetically.
* gnu/packages/astronomy.scm (psfex): Sort alphabetically. Change-Id: I323fdc7b304079b326f99d2781cc4f5b144fa5d7
-rw-r--r--gnu/packages/astronomy.scm90
1 files changed, 45 insertions, 45 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3bfb5a1e0e..3e58c9d5ee 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -631,6 +631,51 @@ applications of EyE include adaptive filtering, feature detection and cosmetic
corrections.")
(license license:cecill)))
+(define-public psfex
+ (package
+ (name "psfex")
+ (version "3.24.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/psfex")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ykgzyxnxjxqk6b8jng006wjilg4fqaxclpfn8plg6brk1qf39sn"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "CPPFLAGS=-fcommon"
+ "--enable-openblas"
+ "--enable-plplot"
+ (string-append "--with-fftw-libdir="
+ #$(this-package-input "fftw") "/lib")
+ (string-append "--with-fftw-incdir="
+ #$(this-package-input "fftw") "/include")
+ (string-append "--with-openblas-libdir="
+ #$(this-package-input "openblas") "/lib")
+ (string-append "--with-openblas-incdir="
+ #$(this-package-input "openblas") "/include")
+ (string-append "--with-plplot-libdir="
+ #$(this-package-input "plplot") "/lib")
+ (string-append "--with-plplot-incdir="
+ #$(this-package-input "plplot") "/include"))))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (inputs
+ (list openblas fftw fftwf plplot))
+ (home-page "https://www.astromatic.net/software/psfex/")
+ (synopsis "Astronomical PSF modelling and quality assessment")
+ (description
+ "@acronym{PSFEx, PSF Extractor} extracts models of the @acronym{PSF,
+Point Spread Function} from FITS images processed with SExtractor, and
+measures the quality of images. The generated PSF models can be used for
+model-fitting photometry or morphological analyses.")
+ (license license:gpl3+)))
+
(define-public python-aplpy
(package
(name "python-aplpy")
@@ -1289,51 +1334,6 @@ programs for the manipulation and analysis of astronomical data.")
from Stark Labs.")
(license license:bsd-3)))
-(define-public psfex
- (package
- (name "psfex")
- (version "3.24.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/astromatic/psfex")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0ykgzyxnxjxqk6b8jng006wjilg4fqaxclpfn8plg6brk1qf39sn"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:configure-flags
- #~(list "CPPFLAGS=-fcommon"
- "--enable-openblas"
- "--enable-plplot"
- (string-append "--with-fftw-libdir="
- #$(this-package-input "fftw") "/lib")
- (string-append "--with-fftw-incdir="
- #$(this-package-input "fftw") "/include")
- (string-append "--with-openblas-libdir="
- #$(this-package-input "openblas") "/lib")
- (string-append "--with-openblas-incdir="
- #$(this-package-input "openblas") "/include")
- (string-append "--with-plplot-libdir="
- #$(this-package-input "plplot") "/lib")
- (string-append "--with-plplot-incdir="
- #$(this-package-input "plplot") "/include"))))
- (native-inputs
- (list autoconf automake libtool pkg-config))
- (inputs
- (list openblas fftw fftwf plplot))
- (home-page "https://www.astromatic.net/software/psfex/")
- (synopsis "Astronomical PSF modelling and quality assessment")
- (description
- "@acronym{PSFEx, PSF Extractor} extracts models of the @acronym{PSF,
-Point Spread Function} from FITS images processed with SExtractor, and
-measures the quality of images. The generated PSF models can be used for
-model-fitting photometry or morphological analyses.")
- (license license:gpl3+)))
-
(define-public sextractor
(package
(name "sextractor")