summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-08 21:51:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-08 22:01:47 +0100
commit09c4818beb3d82d77155c7feaf885fedb23145f3 (patch)
tree397a608a10dc5fefea2a0db8d38e2c8909faba76
parent0d7ec97da02b093a259dbadb73976a3586b20c49 (diff)
gnu: python-qstylizer: Update to 0.2.3.
* gnu/packages/python-xyz.scm (python-qstylizer): Update to 0.2.3. [arguments]: Refresh style. [propagated-inputs]: Remove python-tinycss; add python-tinycss2. [native-inputs]: Remove python-pytest-cov, python-pytest-runner, and python-pytest-xdist. Change-Id: I99bde105d125053e1316372dfbebf90d4236fcc7
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b3205e4fa..745e8cb9db 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18033,7 +18033,7 @@ for atomic file system operations.")
(define-public python-qstylizer
(package
(name "python-qstylizer")
- (version "0.1.10")
+ (version "0.2.3")
(source
(origin
(method git-fetch)
@@ -18042,25 +18042,22 @@ for atomic file system operations.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0zvkn6g1dn51kkw33v8qrlnwlmf5h6sw1ay3bh14ifjr8b9xsjjz"))))
- (build-system python-build-system)
+ (base32 "1n11f63pbqzmb7sj9cj0jq9kv8sfinjqhg7fs0mnfsrici8435br"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:test-target "pytest"
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-pbr-version
- (lambda _
- (setenv "PBR_VERSION" "3.0.1"))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-pbr-version
+ (lambda _
+ (setenv "PBR_VERSION" "3.0.1"))))))
(native-inputs
(list python-pbr
python-pytest
python-pytest-catchlog
- python-pytest-cov
- python-pytest-mock
- python-pytest-runner
- python-pytest-xdist))
+ python-pytest-mock))
(propagated-inputs
- (list python-inflection python-tinycss))
+ (list python-inflection python-tinycss2))
(home-page "https://github.com/blambright/qstylizer")
(synopsis "Qt stylesheet generation utility for PyQt/PySide")
(description "@code{qstylizer} is a Python package designed to help with