summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-13 11:00:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-13 11:00:00 +0300
commit109679cdfaab645d2f35afec9bf1cb1b0d24f767 (patch)
tree02b697292ca189719f28982bfc2292b62749d31f
parented3f818b15d88f75e57db1fd107d8b5c995ceef5 (diff)
Revert "gnu: python-xcffib: Update to 1.4.0."
This reverts commit 56980ea500a1db3c8586972b8abfaf5c4e24f82d. This package includes files which need to be bootstrapped, to produce the bindings matching our version of libxcb.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 557c6d5815..b295d780ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10958,14 +10958,14 @@ ManimPango is internally used in Manim to render (non-LaTeX) text.")
(define-public python-xcffib
(package
(name "python-xcffib")
- (version "1.4.0")
+ (version "0.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "xcffib" version))
(sha256
(base32
- "095na8zk75829c6ahxw658jh4g4qxx115g4a32p7b36kzq6w0xxr"))))
+ "0nkglsm9nbhv238iagmmsjcz6lf1yfdvp5kmspphdj385vz9r50j"))))
(build-system python-build-system)
(inputs
(list libxcb))
@@ -10982,7 +10982,16 @@ ManimPango is internally used in Manim to render (non-LaTeX) text.")
(let ((libxcb (assoc-ref inputs "libxcb")))
(substitute* '("xcffib/__init__.py")
(("soname = ctypes.util.find_library.*xcb.*")
- (string-append "soname = \"" libxcb "/lib/libxcb.so\"\n")))))))))
+ (string-append "soname = \"" libxcb "/lib/libxcb.so\"\n")))
+ #t)))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((doc (string-append (assoc-ref outputs "out") "/share"
+ "/doc/" ,name "-" ,version)))
+ (mkdir-p doc)
+ (copy-file "README.md"
+ (string-append doc "/README.md"))
+ #t))))))
(home-page "https://github.com/tych0/xcffib")
(synopsis "XCB Python bindings")
(description