summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-04-05 21:24:19 -0300
committerVinicius Monego <monego@posteo.net>2024-05-11 14:04:42 -0300
commit1568af95bd505499084723dbc8bba37775739375 (patch)
tree70d2c7fc7c24c6d8464217200bf28881b51d9d6c
parent68c34a7192a492ab1446b13d128ab31f4e8a4825 (diff)
gnu: toxic: Update to 0.15.1.
* gnu/packages/messaging.scm (toxic): Update to 0.15.1. [arguments]: Use G-Expressions. <#:make-flags>: Use gexp variables and cc-for-target. <#:phases>: Remove trailing #t. Change-Id: If1d46888e26b16ffcbbca48dc2c88b921e30c433
-rw-r--r--gnu/packages/messaging.scm38
1 files changed, 17 insertions, 21 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 919ae6aaa7..83463f44c6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2294,7 +2294,7 @@ building the IRC clients and bots.")
(define-public toxic
(package
(name "toxic")
- (version "0.8.4")
+ (version "0.15.1")
(source
(origin
(method git-fetch)
@@ -2302,29 +2302,25 @@ building the IRC clients and bots.")
(url "https://github.com/JFreegman/toxic")
(commit (string-append "v" version))))
(sha256
- (base32 "0p1cmj1kyp506y5xm04mhlznhf5wcylvgsn6b307ms91vjqs3fg2"))
+ (base32 "1cbgw9my7nd8b215a3db2jc74nibi9kj0yk5q3c9dnh306as6wzs"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list
- "CC=gcc"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'enable-python-scripting
- (lambda _
- ;; XXX: For compatibility with Python 3.8, adjust python3-config
- ;; invokation to include --embed; see
- ;; <https://github.com/JFreegman/toxic/issues/533>.
- (substitute* "cfg/checks/python.mk"
- (("python3-config --ldflags")
- "python3-config --ldflags --embed"))
- (setenv "ENABLE_PYTHON" "1")
- #t)))))
+ (list #:tests? #f ; no tests
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'enable-python-scripting
+ (lambda _
+ ;; XXX: For compatibility with Python 3.8, adjust
+ ;; python3-config invocation to include --embed; see
+ ;; <https://github.com/JFreegman/toxic/issues/533>.
+ (substitute* "cfg/checks/python.mk"
+ (("python3-config --ldflags")
+ "python3-config --ldflags --embed"))
+ (setenv "ENABLE_PYTHON" "1"))))))
(inputs
(list c-toxcore
curl