summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-27 20:59:16 +0200
committerRoel Janssen <roel@gnu.org>2021-05-27 20:59:16 +0200
commit167fc141d4e6f054e546322eb06e07dacb3309a3 (patch)
tree266dfcec8301ade427c5364e30f8bd55acc06ea6
parent0b31e45b49af76d02ad760162ffe69d6c3cb854f (diff)
gnu: Add python-helper.
* gnu/packages/python-xyz.scm (python-helper): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 973da15cad..3540d8fb05 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25215,6 +25215,29 @@ versions which have appeared in recent Python releases, but are usable with
older versions of Python and so are packaged here.")
(license license:bsd-3)))
+(define-public python-helper
+ (package
+ (name "python-helper")
+ (version "2.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "helper" version))
+ (sha256
+ (base32
+ "1d2j64wgbggzv5rhvil10zndp2w78wa5np5w0psj122ws9qr9wsa"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)))
+ (propagated-inputs
+ `(("python-logutils" ,python-logutils)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page "https://github.com/gmr/helper")
+ (synopsis "Library for writing configurable applications and daemons")
+ (description
+ "This package provides procedures for quickly writing configurable
+applications and daemons.")
+ (license license:bsd-3)))
+
(define-public python-qtsass
(package
(name "python-qtsass")