summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrit Butler <brit@kingcons.io>2021-01-09 23:18:04 -0500
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-11 21:26:33 +0100
commit1cf31ee074aee411c545e2bde2f08f37596c9d4d (patch)
tree8f8317756589e574ccbe8126c831b20ec374fe9d
parentda4b830c398609d0dd4fcf41a6da1329b70abea3 (diff)
gnu: Add emacs-consult.
* gnu/packages/emacs-xyz.scm (emacs-consult): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 76cbe7e075..1defa61294 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -89,6 +89,7 @@
;;; Copyright © 2020 André A. Gomes <andremegafone@gmail.com>
;;; Copyright © 2020 Jonathan Rostran <rostranjj@gmail.com>
;;; Copyright © 2020 Noah Evans <noah@nevans.me>
+;;; Copyright © 2020 Brit Butler <brit@kingcons.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6983,6 +6984,33 @@ any one of several ways: literally, as a regexp, as an initialism, in the flex
style, or as multiple word prefixes.")
(license license:gpl3+)))
+(define-public emacs-consult
+ ;; There are no tagged releases upstream on GitHub, instead we are using the
+ ;; most recent commit.
+ (let ((commit "ef6bb73a4a46e686826968fa25169e2d59b9a087")
+ (revision "0"))
+ (package
+ (name "emacs-consult")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/consult")
+ (commit commit)))
+ (sha256
+ (base32 "00cnwg2knd820wwx6zg71rr0whpdhqm64gm3qx1mgklk79g7daih"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-selectrum" ,emacs-selectrum)))
+ (home-page "https://github.com/minad/consult")
+ (synopsis "Consulting completing-read")
+ (description "This package provides various handy commands based on the
+Emacs completion function completing-read, which allows to quickly select from a
+list of candidates.")
+ (license license:gpl3+))))
+
(define-public emacs-smartparens
(package
(name "emacs-smartparens")