summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:15:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:34 +0100
commit1de40d1b5ab74a1f263e7c4306ebccd0fef73c1a (patch)
treeb2c25c044223c4cef595ec5508b2795559462249
parentdac6f5e8e5bcc25038e3af97cc269676b57c8411 (diff)
gnu: eye: Sort alphabetically.
* gnu/packages/astronomy.scm (eye): Sort alphabetically. Change-Id: Ifd2af4f8101f95072339e8f801361bdfd57a539c
-rw-r--r--gnu/packages/astronomy.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b1f06edda8..e5b4f84d4b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -601,6 +601,36 @@ Standards of Fundamental Astronomy} library published by the @acronym{IAU,
International Astronomical Union}.")
(license license:bsd-3)))
+(define-public eye
+ (package
+ (name "eye")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/eye")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j8rpgz3fjp6fw0qmxgfqycf3n01fzxds4w12vgyrhbnk658ia41"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "CPPFLAGS=-fcommon"))) ; fix build with GCC 10
+ (home-page "https://www.astromatic.net/software/eye")
+ (synopsis "Small image feature detector using machine learning")
+ (description
+ "In @acronym{EyE, Enhance Your Extraction} an artificial neural network
+connected to pixels of a moving window (@dfn{retina}) is trained to associate
+these input stimuli to the corresponding response in one or several output
+image(s). The resulting filter can be loaded in SExtractor to operate
+complex, wildly non-linear filters on astronomical images. Typical
+applications of EyE include adaptive filtering, feature detection and cosmetic
+corrections.")
+ (license license:cecill)))
+
(define-public python-aplpy
(package
(name "python-aplpy")
@@ -1001,36 +1031,6 @@ zooming windows, star catalog access, cuts, star pick/FWHM, thumbnails, etc.")
(prepend python-pyqt)))
(synopsis "Qt5 image viewer build based on python-ginga library")))
-(define-public eye
- (package
- (name "eye")
- (version "1.4.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/astromatic/eye")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1j8rpgz3fjp6fw0qmxgfqycf3n01fzxds4w12vgyrhbnk658ia41"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:configure-flags
- #~(list "CPPFLAGS=-fcommon"))) ; fix build with GCC 10
- (home-page "https://www.astromatic.net/software/eye")
- (synopsis "Small image feature detector using machine learning")
- (description
- "In @acronym{EyE, Enhance Your Extraction} an artificial neural network
-connected to pixels of a moving window (@dfn{retina}) is trained to associate
-these input stimuli to the corresponding response in one or several output
-image(s). The resulting filter can be loaded in SExtractor to operate
-complex, wildly non-linear filters on astronomical images. Typical
-applications of EyE include adaptive filtering, feature detection and cosmetic
-corrections.")
- (license license:cecill)))
-
(define-public wcslib
(package
(name "wcslib")