summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-09-24 15:28:15 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-26 23:29:37 +0200
commit22c6d4dc142b61a218ee46c0181d69eb3f242e75 (patch)
tree200d261ad97ccdcd749cb221c406e35d53f77b55
parent5c37ad812b94de76ab45bb15a25aaf7895fb0c66 (diff)
gnu: Add ec.
* gnu/packages/linux.scm (ec): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1838c9a2fa..74fb35e55f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
@@ -1342,6 +1343,31 @@ battery charging thresholds, keyboard backlight, fans and thermal monitors,
and the notification, WiFi, and Bluetooth LED.")
(license license:gpl2)))
+(define-public ec
+ (package
+ (name "ec")
+ (version (package-version linux-libre))
+ (source (package-source linux-libre))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags #~(list (string-append "sbindir="
+ #$output "/sbin")
+ "INSTALL=install" "STRIPCMD=true")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'enter-subdirectory
+ (lambda _
+ (chdir "tools/power/acpi/tools/ec")))
+ (delete 'configure)) ;no configure script
+ #:tests? #f)) ;no tests
+ (home-page (package-home-page linux-libre))
+ (synopsis
+ "Utility for reading or writing @acronym{EC, Embedded Controller} registers")
+ (description
+ "This utility can read or write specific registers or all the available
+registers of the @acronym{EC, Embedded Controller} supported by the
+@code{ec_sys} Linux driver.")
+ (license license:gpl2)))
+
(define-public lkrg
(package
(name "lkrg")