summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-12-01 10:49:46 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-12-01 11:52:34 +0100
commit26e92b7e787c2e4a9c6b0cf7206bab773135e220 (patch)
treef1dc18df15066e02819e8bce74090531e5a69a1f
parent718dd9779aa74ab397ff6a69e9bf36e83c3adf5b (diff)
gnu: sbcl-specialized-function: Disable tests.
* gnu/packages/lisp-xyz.scm (sbcl-specialized-function)[arguments]: Disable tests.
-rw-r--r--gnu/packages/lisp-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d49d460db1..79fb41ab1a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8430,7 +8430,11 @@ code. The main target of this macro is speed.")
`(("fiveam" ,sbcl-fiveam)))
(arguments
`(#:asd-files '("specialized-function.asd")
- #:test-asd-file "specialized-function.test.asd")))))
+ #:test-asd-file "specialized-function.test.asd"
+ ;; Tests fail because they try to use an internal symbol of SBCL
+ ;; that does not exists in recent versions:
+ ;; "The variable SB-VM:COMPLEX-VECTOR-NIL-WIDETAG is unbound."
+ #:tests? #f)))))
(define-public cl-specialized-function
(sbcl-package->cl-source-package sbcl-specialized-function))