summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-05-13 19:05:52 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-31 13:55:42 +0200
commit34604cc0faab3696e9183de02808575da4aecd61 (patch)
tree0a0d93b95ef9f21b652d372911b36f2422f7eb59
parent0c87fe868aa94dcf864b79bb2e0a0c6ec2629050 (diff)
gnu: Add python-pybadges.
* gnu/packages/python-web.scm (python-pybadges): New variable. Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c00e38a120..5ca50fa5a6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9224,6 +9224,39 @@ list, create, update, or delete resources (e.g. Order, Product, Collection).")
"This package provides a library to parse and apply patches.")
(license license:expat)))
+(define-public python-pybadges
+ (package
+ (name "python-pybadges")
+ (version "3.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/pybadges")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~'("-k"
+ ;; Disable network dependent tests.
+ "not test_changes and not test_not_image_url and not test_http_url")))
+ (propagated-inputs (list python-jinja2 python-requests))
+ (native-inputs (list python-flask
+ python-fonttools
+ python-nox
+ python-pillow
+ python-pytest
+ python-xmldiff))
+ (home-page "https://github.com/google/pybadges")
+ (synopsis "Generate Github-style badges on the command-line")
+ (description
+ "This package provides @code{python-pybadges}: a library and command-line
+tool for generating Github-style badges as SVG images.")
+ (license license:asl2.0)))
+
(define-public python-grid5000
(package
(name "python-grid5000")