summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-09 07:21:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:56 +0200
commit3556df7323637d23c1b38e6adccdac45745810aa (patch)
tree44b99961b6a3976671a828275b1cf426767f5fe8
parent09283bb0ab560ae50b33a504368d8769a7d04a50 (diff)
gnu: Add texlive-hyphenex.
* gnu/packages/tex.scm (texlive-hyphenex): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index effec09698..f89084b2e5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -982,6 +982,27 @@ the autogenerated files @file{language.dat} and @file{language.def} (and
default versions of those), etc.")
(license license:knuth)))
+(define-public texlive-hyphenex
+ (package
+ (name "texlive-hyphenex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "source/generic/hyphenex/"
+ "tex/generic/hyphenex/")
+ (base32
+ "1v1p93i56xgp01zly30bkfgb9py8nav1r620dbgz1q7438zbhzpp")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/hyphenex")
+ (synopsis "US English hyphenation exceptions file")
+ (description
+ "Exceptions for American English hyphenation patterns are occasionally
+published in the TeX User Group journal TUGboat. This bundle provides
+alternative Perl and Bourne shell scripts to convert the source of such an
+article into an exceptions file, together with a recent copy of the article
+and machine-readable files.")
+ (license license:public-domain)))
+
(define-public texlive-dvipdfmx
(package
(name "texlive-dvipdfmx")