summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-20 00:32:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-03-13 09:49:38 +0100
commit35e4561843df3edad2f85100456276f662a60394 (patch)
treef97b83c3df6be2af40221b255f2473043444df09
parent8bd8484e6da4f3665432615b09eef5459d381ed9 (diff)
gnu: emacs-sway: Update to 0.7-0.84eae5e.
* gnu/packages/emacs-xyz.scm (emacs-sway): Update to 0.7-0.84eae5e. Change-Id: I37549f7e66d9fa1df455af3bc972e49cb79d50ef Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eb3e21968c..164ab4e716 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13091,27 +13091,29 @@ The following completions are currently available:
(license license:gpl3+)))
(define-public emacs-sway
- (package
- (name "emacs-sway")
- (version "0.7")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/thblt/sway.el")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1w29dkl7s835zgwnc4jx1cp84s6mmwbvlil8z2c31psy0rlajc6i"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/thblt/sway.el")
- (synopsis "Communication with the Sway window manager")
- (description
- "This is a basic library to control the Sway window manager from Emacs.
+ (let ((commit "84eae5e16a643eb00b0a422ded751cceb17cc8f0")
+ (revision "0"))
+ (package
+ (name "emacs-sway")
+ (version (git-version "0.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thblt/sway.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "194plzc6rg7a5j3f68say0znix34yp8421cdlkwnw345czh52mjn"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/thblt/sway.el")
+ (synopsis "Communication with the Sway window manager")
+ (description
+ "This is a basic library to control the Sway window manager from Emacs.
Its main use case is in combination with popup managers like Shackle, to
use frames instead of windows while still giving focus to existing frames
instead of duplicating them.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-sweet-theme
(let ((commit "78f741806ecebe01224bf54d09ad80e306652508")