summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbigbug <bigbookofbug@proton.me>2024-05-09 18:11:58 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-05-09 18:13:24 +0200
commit360fea15cb25d0cdf55ec55488956257a0219fe4 (patch)
tree0074364d7e2fdef38e9ec4ab1d79e8decf500d37
parentcf5f7a8bf9ca2288700fcf351bbca0fc341ec969 (diff)
gnu: Add sbcl-stumpwm-binwarp.
* gnu/packages/wm.scm (sbcl-stumpwm-binwarp): New variable. Change-Id: Iddf89b0ed79bcf88b35356197ab283916c87f958 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/wm.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f4c6dbda0a..4068dbe5d4 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -71,6 +71,7 @@
;;; Copyright © 2024 chris <chris@bumblehead.com>
;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2590,6 +2591,23 @@ productive, customizable lisp based systems.")
control module for StumpWM.")
(license license:gpl3))))
+(define-public sbcl-stumpwm-binwarp
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-binwarp")
+ (arguments
+ '(#:asd-systems '("binwarp")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/binwarp"))))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Keyboard-driven divide-and-conquer mouse control mode")
+ (description "This package provides a keyboard-driven divide-and-conquer
+mouse control mode for StumpWM.")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+
(define-public sbcl-stumpwm-ttf-fonts
(package
(inherit stumpwm-contrib)