summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-27 11:28:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:54 +0200
commit495c4868bee3df666ecdb07240cfdcd28b642905 (patch)
treea7e66638536df417e4d3d076ae74bfb49ede6aa8
parentec66a4de9643083c717ffd9fcc34b3c99cec826e (diff)
gnu: rust-git-testament-derive-0.1: Move to (gnu packages crates-vcs).
* gnu/packages/crates-io.scm (rust-git-testament-derive-0.1): Move from here ... * gnu/packages/crates-vcs.scm: ... to here. Change-Id: If002423ef70413d6ced9b2f18d86d625fd5bf9ba
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/crates-io.scm28
-rw-r--r--gnu/packages/crates-vcs.scm53
3 files changed, 55 insertions, 27 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index db18a09f8a..7231aa898b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -204,6 +204,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/crates-io.scm \
%D%/packages/crates-graphics.scm \
%D%/packages/crates-gtk.scm \
+ %D%/packages/crates-vcs.scm \
%D%/packages/cross-base.scm \
%D%/packages/cross-toolchain.scm \
%D%/packages/crypto.scm \
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 03821e8656..4865585838 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -74,6 +74,7 @@
#:use-module (gnu packages cpp)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages crates-gtk)
+ #:use-module (gnu packages crates-vcs)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
@@ -30316,33 +30317,6 @@ debugging format.")
(description "Record git working tree status when compiling your crate")
(license license:bsd-3)))
-(define-public rust-git-testament-derive-0.1
- (package
- (name "rust-git-testament-derive")
- (version "0.1.14")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "git-testament-derive" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1rlais0i47mgsmp3r5jcqry2agjfyg5s9paj6mgvfykchssjsy2a"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-log" ,rust-log-0.4)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1)
- ("rust-time" ,rust-time-0.3))
- #:cargo-development-inputs
- (("rust-git-testament" ,rust-git-testament-0.2))))
- (home-page "https://github.com/kinnison/git-testament/")
- (synopsis "Record git working tree status when compiling your crate")
- (description
- "This package provides an inner procedural macro for git-testament.")
- (license license:bsd-3)))
-
(define-public rust-git-version-0.3
(package
(name "rust-git-version")
diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
new file mode 100644
index 0000000000..f92f14eda0
--- /dev/null
+++ b/gnu/packages/crates-vcs.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages crates-vcs)
+ #:use-module (guix build-system cargo)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages crates-io))
+
+(define-public rust-git-testament-derive-0.1
+ (package
+ (name "rust-git-testament-derive")
+ (version "0.1.14")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "git-testament-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rlais0i47mgsmp3r5jcqry2agjfyg5s9paj6mgvfykchssjsy2a"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-log" ,rust-log-0.4)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1)
+ ("rust-time" ,rust-time-0.3))
+ #:cargo-development-inputs
+ (("rust-git-testament" ,rust-git-testament-0.2))))
+ (home-page "https://github.com/kinnison/git-testament/")
+ (synopsis "Record git working tree status when compiling your crate")
+ (description
+ "This package provides an inner procedural macro for git-testament.")
+ (license license:bsd-3)))