summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-27 23:14:48 +0100
committerChristopher Baines <mail@cbaines.net>2023-11-05 18:09:35 +0000
commit4d4e9b84eeeb767d64f53e3b505302bc02ea44c8 (patch)
tree93ec373c4a5a626c42a7ec8b35bee0f12bf094ad
parent0d7e51d8ee94b0a56e48bc0d301ade965857f38a (diff)
gnu: python-pynbody: Update to 1.4.1.
* gnu/packages/astronomy.scm (python-pynbody): Update to 1.4.1. [source]: Switch to git-fetch. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f902c0da63..bad437557c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3534,13 +3534,21 @@ functions, so that they can be called with scalar or array inputs.")
(define-public python-pynbody
(package
(name "python-pynbody")
- (version "1.3.1")
+ (version "1.4.1")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "pynbody" version))
+ (method git-fetch) ;PyPi doesn't have not prebuit version.
+ (uri (git-reference
+ (url "https://github.com/pynbody/pynbody")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1yp7ja66zqmbnh7bbwbyimxq1nkrmjrcif2rzfm1hswm0fp2fbga"))))
+ (base32 "1vl1yif3bsazcil6saghrpa4qsg47fnr7xnkjpqnp44b7ipww27r"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Symlink goes to not existing directory.
+ #~(for-each delete-file '("docs/testdata"
+ "docs/tutorials/example_code/testdata")))))
(build-system pyproject-build-system)
(arguments
(list #:test-flags #~(list