summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-04-01 14:32:54 -0300
committerVinicius Monego <monego@posteo.net>2024-04-08 21:24:46 -0300
commit51de844a0ff6ea224367a384092896bce6848b9f (patch)
tree3bb623ffd2fa9f72ddc8fe90dae2514146770d9f
parente34ebd7f7366a7f2742a856a86a7399e0027a25b (diff)
gnu: Add pdal.
* gnu/packages/geo.scm (pdal): New variable. Change-Id: I7c24fec69b4f0c19a1c246fab39b994e17e36f3a
-rw-r--r--gnu/packages/geo.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ead7964562..c30f28d96f 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -101,6 +101,7 @@
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages java)
#:use-module (gnu packages kde)
+ #:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
@@ -1229,6 +1230,47 @@ development.")
(home-page "https://www.gaia-gis.it/fossil/spatialite_gui/index")
(license license:gpl3+)))
+(define-public pdal
+ (package
+ (name "pdal")
+ (version "2.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PDAL/PDAL")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gg5lcshlmn3wwak42xr0b8a8gdr4572d7hrcvxn2291kp2c3096"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E" ;; This test hangs.
+ "pdal_io_stac_reader_test")))))))
+ (native-inputs (list python))
+ (inputs (list gdal
+ h3
+ libgeotiff
+ libunwind
+ libxml2
+ nlohmann-json
+ openssl
+ proj
+ utfcpp
+ xz
+ `(,zstd "lib")))
+ (home-page "https://pdal.io/")
+ (synopsis "Point Data Abstraction Library")
+ (description "PDAL is a C++ library for translating and manipulating point
+cloud data. It is very much like the GDAL library which handles raster and
+vector data.")
+ (license license:bsd-3)))
+
(define-public gdal
(package
(name "gdal")