summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 22:19:44 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:02 +0000
commit547eec541d3c1258a1d0a63b76e2f554715b6acd (patch)
tree7880df504530a0ae204feadcba7a529ecad193be
parent0493c9cb199497bb750ab319710646b8546c539a (diff)
gnu: go-github-com-multiformats-go-multihash: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-multiformats-go-multihash): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/ipfs.scm: Add (gnu packages golang-crypto) to used modules. * gnu/packages/golang.scm: ... as above. Change-Id: I153be971141cf60390d03bf589c5121d9554cf9a
-rw-r--r--gnu/packages/golang-crypto.scm31
-rw-r--r--gnu/packages/golang.scm32
-rw-r--r--gnu/packages/ipfs.scm1
3 files changed, 33 insertions, 31 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 38ccc5ffe9..96e12a1194 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,36 @@
;;;
;;; Code:
+(define-public go-github-com-multiformats-go-multihash
+ (let ((commit "97cdb562a04c6ef66d8ed40cd62f8fbcddd396d6")
+ (revision "0"))
+ (package
+ (name "go-github-com-multiformats-go-multihash")
+ (version (git-version "1.0.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multihash")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02wd9akrwy4y5m0nig9m24p14bjjgb4n1djydrq8cm4yhbvjrrk0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/multiformats/go-multihash"))
+ (native-inputs
+ (list go-github-com-mr-tron-base58
+ go-github-com-gxed-hashland-keccakpg
+ go-github-com-minio-blake2b-simd
+ go-github-com-minio-sha256-simd
+ go-github-com-spaolacci-murmur3
+ go-golang-org-x-crypto))
+ (home-page "https://github.com/multiformats/go-multihash")
+ (synopsis "Multihash implementation in Go")
+ (description "Multihash implementation in Go.")
+ (license license:expat))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 31107b8c8d..2042a03ef6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -81,6 +81,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-web)
#:use-module (gnu packages lua)
#:use-module (gnu packages mail)
@@ -6136,37 +6137,6 @@ Reference algorithm has been slightly hacked as to support the streaming mode
required by Go's standard Hash interface.")
(license license:bsd-3)))
-(define-public go-github-com-multiformats-go-multihash
- (let ((commit "97cdb562a04c6ef66d8ed40cd62f8fbcddd396d6")
- (revision "0"))
- (package
- (name "go-github-com-multiformats-go-multihash")
- (version (git-version "1.0.8" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/multiformats/go-multihash")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "02wd9akrwy4y5m0nig9m24p14bjjgb4n1djydrq8cm4yhbvjrrk0"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/multiformats/go-multihash"))
- (native-inputs
- (list go-github-com-mr-tron-base58
- go-github-com-gxed-hashland-keccakpg
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-spaolacci-murmur3
- go-golang-org-x-crypto))
- (home-page "https://github.com/multiformats/go-multihash")
- (synopsis "Multihash implementation in Go")
- (description "Multihash implementation in Go.")
- (license license:expat))))
-
(define-public go-github-com-libp2p-go-libp2p-peer
(let ((commit "993d742bc29dcf4894b7730ba610fd78900be76c")
(revision "0"))
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 87d5086feb..df00287460 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -30,6 +30,7 @@
#:use-module (guix build-system go)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-web)
#:use-module (gnu packages python)
#:use-module (gnu packages shells)