summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:07:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:34 +0100
commit57334d189dc326594ffde8858af5d2b86f64e354 (patch)
tree3ba33f06b64ee1242d2adb18d827e1be8322264a
parent43747274c38f2bb31f4407eedd3b0daed11f741c (diff)
gnu: python-astroalign: Sort alphabetically.
* gnu/packages/astronomy.scm (python-astroalign): Sort alphabetically. Change-Id: I114f79715ec0d9ecebd1858ae45661558b399a14
-rw-r--r--gnu/packages/astronomy.scm66
1 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a5cd0162ef..bc0000070b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -689,6 +689,39 @@ interchange format for scientific data. This package contains the Python
implementation of the ASDF Standard.")
(license license:bsd-3)))
+(define-public python-astroalign
+ (package
+ (name "python-astroalign")
+ (version "2.5.1")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quatrope/astroalign")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kr5cszcxvrdbksy7mvv3ps1h1jzrn4yamfr6x7whkbi6bpqf7xp"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-astropy
+ python-ccdproc
+ python-pillow
+ python-pytest))
+ (propagated-inputs
+ (list python-bottleneck
+ python-numpy
+ python-scikit-image
+ python-scipy
+ python-sep))
+ (home-page "https://astroalign.readthedocs.io/")
+ (synopsis "Astrometric Alignment of Images")
+ (description
+ "ASTROALIGN is a python module that will try to align two stellar
+astronomical images, especially when there is no WCS information available.")
+ (license license:expat)))
+
(define-public python-astroml
(package
(name "python-astroml")
@@ -4952,39 +4985,6 @@ for Roman since FITS format data files will not be used by the Roman calibration
pipelines.")
(license license:bsd-3)))
-(define-public python-astroalign
- (package
- (name "python-astroalign")
- (version "2.5.1")
- (source
- (origin
- ;; There are no tests in the PyPI tarball.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/quatrope/astroalign")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1kr5cszcxvrdbksy7mvv3ps1h1jzrn4yamfr6x7whkbi6bpqf7xp"))))
- (build-system pyproject-build-system)
- (native-inputs
- (list python-astropy
- python-ccdproc
- python-pillow
- python-pytest))
- (propagated-inputs
- (list python-bottleneck
- python-numpy
- python-scikit-image
- python-scipy
- python-sep))
- (home-page "https://astroalign.readthedocs.io/")
- (synopsis "Astrometric Alignment of Images")
- (description
- "ASTROALIGN is a python module that will try to align two stellar
-astronomical images, especially when there is no WCS information available.")
- (license license:expat)))
-
(define-public python-skyfield
(package
(name "python-skyfield")