summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-11 16:12:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-11 17:12:54 +0200
commit5e07608a306fdd8d2f92c330aba2de6946958dfa (patch)
tree683127b215429fe836da554db8c898d7ff92227e
parent1e4c45b0dc1bc0bbfe064cedf22573ab70812562 (diff)
gnu: Add python-adjusttext.
* gnu/packages/python-xyz.scm (python-adjusttext): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 23afc0f282..5fe5b31979 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -621,6 +621,29 @@ remembers the order in which the items were inserted and supports almost all the
features of the Python's built-in dict.")
(license license:unlicense)))
+(define-public python-adjusttext
+ (package
+ (name "python-adjusttext")
+ (version "0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "adjustText" version))
+ (sha256
+ (base32
+ "05zf0xn7ab40dan213fwbp1z4rybih8dphf9mzb2ddmbafxq41mv"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-matplotlib python-numpy))
+ (home-page "https://github.com/Phlya/adjustText")
+ (synopsis "Adjust text position in matplotlib plots to minimize overlaps")
+ (description
+ "Often when we want to label multiple points on a graph the text will
+start heavily overlapping with both other labels and data points. This can be
+a major problem requiring manual solution. However this can be largely
+automatized by smart placing of the labels (difficult) or iterative adjustment
+of their positions to minimize overlaps (relatively easy). This library
+implements the latter option to help with matplotlib graphs.")
+ (license license:expat)))
+
(define-public python-argopt
(package
(name "python-argopt")