summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:53:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:53:29 +0200
commit6f9d017f0fcd76e4f0be4ab22f282c7ef90d54f2 (patch)
tree5a9f4a13d95100e979ce4f5883de8fd1dd753c51
parent5ea5e8696f9fe761951345d634f05f4f4ce37c67 (diff)
gnu: Add texlive-kanbun.
* gnu/packages/tex.scm (texlive-kanbun): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bf2e5bfbfa..7447855350 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34400,6 +34400,26 @@ somewhat from the standard LaTeX writing style. This package introduces
mathematical equation representation in Japanese education.")
(license license:expat)))
+(define-public texlive-kanbun
+ (package
+ (name "texlive-kanbun")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/kanbun/" "tex/latex/kanbun/")
+ (base32
+ "1a922jly8f791r4jbz4097h8js5z29435zphm5i52pvkl6p245wy")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/kanbun")
+ (synopsis "Typeset kanbun-kundoku with support for kanbun annotation")
+ (description
+ "This package allows users to manually input macros for elements in
+a kanbun-kundoku (Han Wen Xun Du) paragraph. More importantly, it accepts
+plain text input in the kanbun annotation form when used with LuaLaTeX, which
+allows typesetting kanbun-kundoku paragraphs efficiently.")
+ (license license:lppl1.3+)))
+
(define-public texlive-libertine
(package
(name "texlive-libertine")