summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-08 22:13:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 18:45:32 +0100
commit75a9ee5b8e59ac02b6ab8051bd30fbb7454e509c (patch)
tree1e7d5bb666c1b4e14a0d1b1ae22175e26739a810
parent61124bc7b0b03dd9c1208446109e91fbc147bc03 (diff)
gnu: Add r-anytime.
* gnu/packages/cran.scm (r-anytime): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d904e5d00e..6623636e2c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25878,6 +25878,30 @@ They are based on clustering, the statistical concept of data depth,
statistical shape analysis and archetypal analysis.")
(license license:gpl2+)))
+(define-public r-anytime
+ (package
+ (name "r-anytime")
+ (version "0.3.9")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "anytime" version))
+ (sha256
+ (base32
+ "0jjpqynai5nd7mfy1smb44356f3d5bmpxhs1i9x9jw5c959c35hh"))))
+ (properties `((upstream-name . "anytime")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-bh
+ r-rcpp))
+ (home-page "http://dirk.eddelbuettel.com/code/anytime.html")
+ (synopsis "Converter of input to POSIXct or Date")
+ (description
+ "The package converts the input in any one of character, integer, numeric,
+factor, or an ordered type into @code{POSIXct} (or @code{Date}) objects, using
+one of a number of predefined formats, and relying on Boost facilities for date
+and time parsing.")
+ (license license:gpl2+)))
+
(define-public r-anndata
(package
(name "r-anndata")