summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndre A. Gomes <andremegafone@gmail.com>2024-05-31 17:02:18 +0300
committerGuillaume Le Vaillant <glv@posteo.net>2024-06-03 16:57:02 +0200
commit78ecc653b841b329cde93f4d176f510306e3a808 (patch)
tree694d588637ce25804daa838619fc3aac5fbe0768
parent1615084a9a4115d48b75b3db048761e7534efc87 (diff)
gnu: cl-quri: Update to 0.7.0-0.03ecaf3.
* gnu/packages/lisp-xyz.scm (sbcl-quri): Update to 0.7.0-0.03ecaf3. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Change-Id: I688d5d696ac88eff16fa806c4dab747b58653201
-rw-r--r--gnu/packages/lisp-xyz.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index adcd06aa3f..4551dc96ad 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -24472,28 +24472,30 @@ function @code{?} is abbreviation wrapper for @code{quicksearch}.")
(sbcl-package->ecl-package sbcl-quicksearch))
(define-public sbcl-quri
- (package
- (name "sbcl-quri")
- (version "0.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fukamachi/quri")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0l1jnvvkyaxbf08lnqfdbv6lrkq02iqr3y3rwvqxm4fvnzp7mnpz"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs (list sbcl-prove))
- (inputs (list sbcl-babel sbcl-split-sequence sbcl-cl-utilities
- sbcl-alexandria))
- (home-page "https://github.com/fukamachi/quri")
- (synopsis "Yet another URI library for Common Lisp")
- (description
- "QURI (pronounced \"Q-ree\") is yet another URI library for Common
+ (let ((commit "03ecaf3771561d713e58a9c5c22b4d95a7592527")
+ (revision "0"))
+ (package
+ (name "sbcl-quri")
+ (version (git-version "0.7.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fukamachi/quri")
+ (commit commit)))
+ (file-name (git-file-name "cl-quri" version))
+ (sha256
+ (base32 "1dd96mvgwbs799qzh7amc7kgwy84qhi1gw1yj08n83wmy5k4b9k2"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs (list sbcl-prove))
+ (inputs (list sbcl-babel sbcl-split-sequence sbcl-cl-utilities
+ sbcl-alexandria))
+ (home-page "https://github.com/fukamachi/quri")
+ (synopsis "Yet another URI library for Common Lisp")
+ (description
+ "QURI (pronounced \"Q-ree\") is yet another URI library for Common
Lisp. It is intended to be a replacement of PURI.")
- (license license:bsd-3)))
+ (license license:bsd-3))))
(define-public cl-quri
(sbcl-package->cl-source-package sbcl-quri))