summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2024-05-18 12:29:04 +0200
committerjgart <jgart@dismail.de>2024-06-11 13:12:26 -0500
commit7daf9328921f9f7d4fe4839d8e16091bd9f06072 (patch)
treeea09f63ab1577bb434e0180ae31fa6195906034f
parent363b50f579c8f6d15123439f76ea6d47c0dcd86d (diff)
gnu: cmus: Switch to new package style.
* gnu/packages/music.scm (cmus): Switch to new style. [arguments]: Use g-exps. Drop trailing #t from 'configure phase. Change-Id: Ia840202adddf390bd29a0fb57fa1a3294dd7a61a Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/music.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 772fe411ef..a920da76fb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -827,17 +827,15 @@ It is a fork of Clementine aimed at music collectors and audiophiles.")
"1k50z99v2yqshycx6mbk4g5bsaalg5dgzjv3xvwq14abwkw44hli"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; cmus does not include tests
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; It's an idiosyncratic configure script that doesn't
- ;; understand --prefix=..; it wants prefix=.. instead.
- (invoke "./configure"
- (string-append "prefix=" out))
- #t))))))
+ (list
+ #:tests? #f ; cmus does not include tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ ;; It's an idiosyncratic configure script that doesn't
+ ;; understand --prefix=..; it wants prefix=.. instead.
+ (invoke "./configure" (string-append "prefix=" #$output)))))))
;; TODO: cmus optionally supports the following formats, which haven't yet
;; been added to Guix:
;;