summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-05 16:21:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 15:37:15 +0100
commit85d5ce49015dfd93c1b3d37cafe83d017eedcfd4 (patch)
tree14bd32f0c875d7883f00b41df50f33437860104d
parent97b36ca4d3ab99190962a90da9627d559475dbd9 (diff)
gnu: Add r-altcdfenvs.
* gnu/packages/bioconductor.scm (r-altcdfenvs): New variable.
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1d1aae322c..fbd23d0f6d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2492,6 +2492,37 @@ mapped reads). It is currently designed for un-stranded paired-end RNA-seq
data.")
(license license:gpl2+)))
+(define-public r-altcdfenvs
+ (package
+ (name "r-altcdfenvs")
+ (version "2.60.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "altcdfenvs" version))
+ (sha256
+ (base32
+ "0fm4l93j6nm1w1w57zzryc1hkzapp8l16pkwjzdzllvwvsnsg8r0"))))
+ (properties `((upstream-name . "altcdfenvs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-biobase
+ r-biocgenerics
+ r-biostrings
+ r-hypergraph
+ r-makecdfenv
+ r-s4vectors))
+ (home-page "https://bioconductor.org/packages/altcdfenvs")
+ (synopsis
+ "Convenience data structures and functions to handle CDF environments")
+ (description
+ "The package is usable with Affymetrix GeneChip short oligonucleotide
+arrays, and it can be adapted or extended to other platforms. It is able to
+modify or replace the grouping of probes in the probe sets. Also, the package
+contains simple functions to read R connections in the FASTA format and it can
+create an alternative mapping from sequences.")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")