summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-05-09 15:35:41 +0100
committerChristopher Baines <mail@cbaines.net>2024-05-13 12:01:49 +0100
commit8fb98fe33b01610ad37fc27a1db6d758a3eec283 (patch)
tree8fa403b4f93826466e1196d22772ef8ff1f44157
parent31d1cc82b325d8b17e21c5a22e9aea6c24cffe90 (diff)
gnu: Add po4a-minimal.
The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in nss, which has a very time consuming testsuite. * gnu/packages/gettext.scm (po4a-minimal): New variable. Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4
-rw-r--r--gnu/packages/gettext.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 1408cc4cb4..31fe95f6ad 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -317,3 +317,15 @@ from Markdown files.")
more interestingly, the maintenance of translations) using gettext tools on
areas where they were not expected like documentation.")
(license gpl2+)))
+
+(define-public po4a-minimal
+ (package/inherit po4a
+ (native-inputs
+ ;; Remove test dependencies, primarily to reduce the size of the
+ ;; dependency graph of the ‘guix’ package.
+ (modify-inputs (package-native-inputs po4a)
+ (delete "docbook-xml" "perl-test-pod" "texlive-updmap.cfg")))
+ (arguments
+ (substitute-keyword-arguments (package-arguments po4a)
+ ((#:tests? _ #t) #f)))
+ (properties '((hidden? . #t)))))