summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:01 +0200
commit943a5b1ee787c2a34fec8431b686a4387c1cc2de (patch)
tree1ca04ae35fbda891bda459cd9115cb47d1fd08a3
parent090667a258a8d2b2268772dd74d7480c058b5adf (diff)
gnu: lldpd: Use G-expressions.
* gnu/packages/networking.scm (lldpd)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 0b961f4751..33b702c8ec 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4035,17 +4035,16 @@ thousands of connections is clearly realistic with today's hardware.")
;; Drop bundled library.
(delete-file-recursively "libevent")))))
(arguments
- `(#:configure-flags
- (list
- "--with-privsep-user=nobody"
- "--with-privsep-group=nogroup"
- "--localstatedir=/var"
- "--enable-pie"
- "--disable-static"
- "--without-embedded-libevent"
- (string-append "--with-systemdsystemunitdir="
- (assoc-ref %outputs "out")
- "/lib/systemd/system"))))
+ (list #:configure-flags
+ #~(list
+ "--with-privsep-user=nobody"
+ "--with-privsep-group=nogroup"
+ "--localstatedir=/var"
+ "--enable-pie"
+ "--disable-static"
+ "--without-embedded-libevent"
+ (string-append "--with-systemdsystemunitdir="
+ #$output "/lib/systemd/system"))))
(build-system gnu-build-system)
(inputs
(list libevent libxml2 openssl readline))