summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-07 21:57:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-07 21:57:47 +0200
commit95d5795a99c585c6ff169df7fec87c0dfcb7f865 (patch)
tree8cbbbb77209160eb614ea8fa10dc3d584dd37dde
parent3571e4752501fb0f7da7785a3834009f522eb24c (diff)
gnu: powertabeditor: Update to 2.0.0-alpha19.
* gnu/packages/music.scm (powertabeditor): Update to 2.0.0-alpha19. [arguments]: Remove 'fix-pugixml-detection phase; respect #:tests? setting in custom 'check phase. [inputs]: Drop labels; add nlohmann-json and qttools-5; remove rapidjson. [home-page]: Add missing letter. Change-Id: Idf8617f3d39dd97ba59753fc7294515032f1656d
-rw-r--r--gnu/packages/music.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 0a14a11b50..a4feada47d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2187,7 +2187,7 @@ your own lessons.")
(define-public powertabeditor
(package
(name "powertabeditor")
- (version "2.0.0-alpha14")
+ (version "2.0.0-alpha19")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2196,30 +2196,29 @@ your own lessons.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wsvni2aa9h2bpndlic7ckch4n600ahwm56n521y5vxivwjx3jmj"))))
+ "1fbrfw1ky57nms47pcfdrrwpa2jmgc8vgc68sz96wkvs49zzm5d1"))))
(build-system cmake-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check (lambda _ (invoke "bin/pte_tests")))
- (add-after 'unpack 'fix-pugixml-detection
- (lambda _
- (substitute* "cmake/third_party/pugixml.cmake"
- (("add_library") "#add_library"))
- #t)))))
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "bin/pte_tests")))))))
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("boost" ,boost)
- ("minizip" ,minizip)
- ("pugixml" ,pugixml)
- ("qtbase" ,qtbase-5)
- ("rapidjson" ,rapidjson)
- ("rtmidi" ,rtmidi)
- ("timidity" ,timidity++)
- ("zlib" ,zlib)))
+ (list alsa-lib
+ boost
+ minizip
+ nlohmann-json
+ pugixml
+ qtbase-5
+ qttools-5 ;for Qt5LinguistTools
+ rtmidi
+ timidity++
+ zlib))
(native-inputs
(list doctest pkg-config))
- (home-page "https://github.com/powertab/powertabedito")
+ (home-page "https://github.com/powertab/powertabeditor")
(synopsis "Guitar tablature editor")
(description
"Power Tab Editor 2.0 is the successor to the famous original Power Tab