summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-26 19:23:19 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-28 20:30:43 +0200
commit9c02f19d6de8a09b90f3bca7c0eba5dd86f4edc0 (patch)
tree1d42a6ba1dc6c3edaf7c1df818c7eef401faca62
parentf1e8cc6a9826f951fe95dc374b4db6fc8e25d981 (diff)
gnu: gst-plugins-good: Update to 1.20.3.
* gnu/packages/gstreamer.scm (gst-plugins-good): Update to 1.20.3. [source]<patches>: Remove “gst-plugins-good-fix-test.patch”. [arguments]<#:phases>: Add ‘absolutize-libsoup-library’ and ‘skip-failing-tests’. * gnu/packages/patches/gst-plugins-good-fix-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gstreamer.scm19
-rw-r--r--gnu/packages/patches/gst-plugins-good-fix-test.patch94
3 files changed, 16 insertions, 98 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 33b8194dc1..bb8514c0d9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1226,7 +1226,6 @@ dist_patch_DATA = \
%D%/packages/patches/grub-efi-fat-serial-number.patch \
%D%/packages/patches/grub-setup-root.patch \
%D%/packages/patches/gspell-dash-test.patch \
- %D%/packages/patches/gst-plugins-good-fix-test.patch \
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
%D%/packages/patches/guile-2.2-skip-oom-test.patch \
%D%/packages/patches/guile-2.2-skip-so-test.patch \
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 0f655db067..b781fa06e9 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -608,7 +608,7 @@ for the GStreamer multimedia library.")
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
- (version "1.18.5")
+ (version "1.20.3")
(source
(origin
(method url-fetch)
@@ -616,15 +616,28 @@ for the GStreamer multimedia library.")
(string-append
"https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
- (patches (search-patches "gst-plugins-good-fix-test.patch"))
(sha256
- (base32 "0svrapawych2s3lm4lx3x023zxq5kcx50jnfmh0qigszfskyxbis"))))
+ (base32 "1dv8b2md1xk6d45ir1wzbvqhxbvm6mxv881rjl0brnjwpw3c5wzq"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
(modify-phases %standard-phases
,@%common-gstreamer-phases
+ (add-after 'unpack 'absolutize-libsoup-library
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define libsoup
+ (search-input-file inputs "lib/libsoup-3.0.so"))
+
+ (substitute* "ext/soup/gstsouploader.c"
+ (("(#define LIBSOUP_3_SONAME ).+$" _ prefix)
+ (string-append prefix "\"" libsoup "\"\n")))))
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ (substitute* "tests/check/meson.build"
+ ;; Reported as shaky upstream, see
+ ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/785>
+ (("\\[ 'elements/flvmux' \\]") "[ 'elements/flvmux', true ]"))))
(add-before 'check 'pre-check
(lambda _
;; Tests require a running X server.
diff --git a/gnu/packages/patches/gst-plugins-good-fix-test.patch b/gnu/packages/patches/gst-plugins-good-fix-test.patch
deleted file mode 100644
index 38ec0ba802..0000000000
--- a/gnu/packages/patches/gst-plugins-good-fix-test.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-Fix a broken test:
-
-https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues/803
-
-Patches copied from upstream source repository:
-
-https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/commit/2ce5909f3a0b0da3abb7b794215d6b8b72a3b7fa
-https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/commit/f5310ce346180a717f091f2f09bcbb3ddfb15436
-
-From 2ce5909f3a0b0da3abb7b794215d6b8b72a3b7fa Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
-Date: Thu, 12 Nov 2020 23:38:21 +0000
-Subject: [PATCH 1/2] tests: qtdemux: fix crash on 32-bit architectures
-
-Fixes https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues/803
-
-Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/merge_requests/815>
----
- tests/check/elements/qtdemux.c | 14 ++++++++------
- 1 file changed, 8 insertions(+), 6 deletions(-)
-
-diff --git a/tests/check/elements/qtdemux.c b/tests/check/elements/qtdemux.c
-index 5271c6576..0c748278b 100644
---- a/tests/check/elements/qtdemux.c
-+++ b/tests/check/elements/qtdemux.c
-@@ -797,9 +797,10 @@ GST_START_TEST (test_qtdemux_pad_names)
- "protection-system", G_TYPE_STRING,
- "9a04f079-9840-4286-ab92-e65be0885f95", NULL);
- caps =
-- gst_caps_new_simple ("video/quicktime", "variant", G_TYPE_STRING,
-- "mss-fragmented", "timesacle", G_TYPE_UINT64, 10000000, "media-caps",
-- GST_TYPE_CAPS, mediacaps, NULL);
-+ gst_caps_new_simple ("video/quicktime",
-+ "variant", G_TYPE_STRING, "mss-fragmented",
-+ "timesacle", G_TYPE_UINT64, G_GUINT64_CONSTANT (10000000),
-+ "media-caps", GST_TYPE_CAPS, mediacaps, NULL);
-
- /* Send segment event* */
- event = gst_event_new_caps (caps);
-@@ -852,9 +853,10 @@ GST_START_TEST (test_qtdemux_pad_names)
- "protection-system", G_TYPE_STRING,
- "9a04f079-9840-4286-ab92-e65be0885f95", NULL);
- caps =
-- gst_caps_new_simple ("video/quicktime", "variant", G_TYPE_STRING,
-- "mss-fragmented", "timesacle", G_TYPE_UINT64, 10000000, "media-caps",
-- GST_TYPE_CAPS, mediacaps, NULL);
-+ gst_caps_new_simple ("video/quicktime",
-+ "variant", G_TYPE_STRING, "mss-fragmented",
-+ "timesacle", G_TYPE_UINT64, G_GUINT64_CONSTANT (10000000),
-+ "media-caps", GST_TYPE_CAPS, mediacaps, NULL);
-
- /* Send segment event* */
- event = gst_event_new_caps (caps);
---
-2.30.0
-
-
-From f5310ce346180a717f091f2f09bcbb3ddfb15436 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
-Date: Thu, 12 Nov 2020 23:39:21 +0000
-Subject: [PATCH 2/2] tests: qtdemux: fix typo in caps field
-
-timesacle -> timescale
-
-Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/merge_requests/815>
----
- tests/check/elements/qtdemux.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/check/elements/qtdemux.c b/tests/check/elements/qtdemux.c
-index 0c748278b..4a14c45c0 100644
---- a/tests/check/elements/qtdemux.c
-+++ b/tests/check/elements/qtdemux.c
-@@ -799,7 +799,7 @@ GST_START_TEST (test_qtdemux_pad_names)
- caps =
- gst_caps_new_simple ("video/quicktime",
- "variant", G_TYPE_STRING, "mss-fragmented",
-- "timesacle", G_TYPE_UINT64, G_GUINT64_CONSTANT (10000000),
-+ "timescale", G_TYPE_UINT64, G_GUINT64_CONSTANT (10000000),
- "media-caps", GST_TYPE_CAPS, mediacaps, NULL);
-
- /* Send segment event* */
-@@ -855,7 +855,7 @@ GST_START_TEST (test_qtdemux_pad_names)
- caps =
- gst_caps_new_simple ("video/quicktime",
- "variant", G_TYPE_STRING, "mss-fragmented",
-- "timesacle", G_TYPE_UINT64, G_GUINT64_CONSTANT (10000000),
-+ "timescale", G_TYPE_UINT64, G_GUINT64_CONSTANT (10000000),
- "media-caps", GST_TYPE_CAPS, mediacaps, NULL);
-
- /* Send segment event* */
---
-2.30.0
-