summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 00:02:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 00:10:13 -0400
commitab2f4548a6d4a89d4f24cd54ab13e3d465ba0e6e (patch)
tree942275113dcc36287f95b7e0cf5a9dc785fc2c83
parent52518b647852fff734cfaed8b1e7742bedf15132 (diff)
gnu: python-pillow: Ungraft.
* gnu/packages/python-xyz.scm (python-pillow): Ungraft, preserving... [source]: ... the CVE patch. (python-pillow/security-fixes): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5d7b2f912c..0f2b801046 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7826,7 +7826,6 @@ retrieve text and metadata from PDFs as well as merge entire files together.")
(package
(name "python-pillow")
(version "9.2.0")
- (replacement python-pillow/security-fixes)
(source (origin
(method url-fetch)
(uri (pypi-uri "Pillow" version))
@@ -7835,7 +7834,9 @@ retrieve text and metadata from PDFs as well as merge entire files together.")
"011wgm1mssjchpva9wsi2a07im9czyjvik137xlp5f0g7vykdrkm"))
(modules '((guix build utils)))
(snippet '(begin
- (delete-file-recursively "src/thirdparty")))))
+ (delete-file-recursively "src/thirdparty")))
+ (patches
+ (search-patches "python-pillow-CVE-2022-45199.patch"))))
(build-system python-build-system)
(native-inputs (list python-pytest))
(inputs (list freetype
@@ -7874,10 +7875,6 @@ a general image processing tool.")
"http://www.pythonware.com/products/pil/license.htm"
"The PIL Software License"))))
-(define-public python-pillow/security-fixes
- (package-with-patches python-pillow
- (search-patches "python-pillow-CVE-2022-45199.patch")))
-
(define-public python-pillow-2.9
(package
(inherit python-pillow)