summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-06-16 10:34:58 +0200
committerjgart <jgart@dismail.de>2024-06-16 11:54:22 -0500
commitb554dc2bdf4be2b51df77ff60b4386c9e640a30e (patch)
tree6936ca56800f12f0d4c485129522c04affba2e9f
parent2195f70936b7aeec123d4e95345f1007d3a7bb06 (diff)
gnu: python-shtab: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-shtab): [build-system]: Move to pyproject-build-system. [arguments]: Remove uneeded field. Change-Id: I3c6cffb85d7335956adc3aa5a17fdf249dac6740 Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3ec3c00cb9..ff371620a6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -35363,7 +35363,7 @@ adapted from the @code{packaging} package.")
(uri (pypi-uri "shtab" version))
(sha256
(base32 "127mymfm7r0hddk2vknqq34fj6dirj6ip990i3g4isx0lsd7pnsc"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(native-inputs
(list bash
python-pytest
@@ -35371,15 +35371,6 @@ adapted from the @code{packaging} package.")
python-pytest-timeout
python-setuptools-scm
python-wheel))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace
- 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest")))))))
(home-page "https://github.com/iterative/shtab")
(synopsis "Automagic shell tab completion for Python CLI applications")
(description