summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-06-06 22:21:02 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-06-06 22:21:02 +0200
commitb8780f7397dd46b5e382e48db87b8648f769d738 (patch)
tree906b8afa0457d4e05930b6305aa7f5e6afa929f8
parent6eb07c78a909be30c4643a794ec0df6e9b56daeb (diff)
parentad7505d16f882e69926008a22f9c12c37b32f4ee (diff)
Merge branch 'gnome-team'
-rw-r--r--gnu/packages/gnome.scm12
-rw-r--r--gnu/packages/gstreamer.scm4
-rw-r--r--gnu/packages/gtk.scm35
-rw-r--r--gnu/packages/qt.scm3
-rw-r--r--gnu/packages/virtualization.scm8
-rw-r--r--gnu/packages/webkit.scm18
6 files changed, 62 insertions, 18 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b9676ffd57..e910e125d2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4553,7 +4553,7 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.56.14")
+ (version "0.56.16")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/vala/"
@@ -4561,7 +4561,7 @@ passwords in the GNOME keyring.")
"vala-" version ".tar.xz"))
(sha256
(base32
- "0mzmldhf6474dp2jkxj160kkafdz32c2l5f8xnm05p4vr9lc50lk"))))
+ "16yaiff5nl2dfyvs3bj8y7wvzh9riz6wqlx7csgg1lpm01b7nj05"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
@@ -13420,6 +13420,14 @@ libraries. Applications do not need to be recompiled--or even restarted.")
#:configure-flags #~(list "-Dnetwork_tests=false" "-Ddocs=true")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; With Gnome 4.14, GtkStackPage has an autoptr already, so it'd
+ ;; get redefined. Drop this phase when updating gnome-builder to
+ ;; 46.0 or newer. See also
+ ;; <https://gitlab.gnome.org/GNOME/gnome-builder/-/commit/7aaaecefc2ea8a37eaeae8b4d726d119d4eb8fa3>
+ (substitute* "src/libide/tweaks/ide-tweaks-window.c"
+ (("G_DEFINE_AUTOPTR_CLEANUP_FUNC \\(GtkStackPage, .*\\)") ""))))
(add-after 'unpack 'patch-meson
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "meson.build"
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 2705e245ea..ad08285181 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -796,6 +796,10 @@ model to base your own plug-in on, here it is.")
;; The 'elements_curlhttpsrc' test sometimes times out.
((".*'elements/curlhttpsrc\\.c'.*") "")
+ ;; Unexpected critical/warning, see
+ ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/3000>
+ ((".*'elements/netsim\\.c'.*") "")
+
;; TODO: Figure out why this test fails on riscv64-linux.
#$@(if (target-riscv64?)
`((("'elements/viewfinderbin\\.c'\\].*],")
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index fdf1fd9251..1c78a969f6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1140,7 +1140,7 @@ application suites.")
(define-public gtk
(package
(name "gtk")
- (version "4.12.3")
+ (version "4.14.2")
(source
(origin
(method url-fetch)
@@ -1148,7 +1148,7 @@ application suites.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "128ahzsj016vz8brd8kplhfkxg2q7wy7kndibx2qfr68yrif530l"))
+ (base32 "0wp0w259rkwf6g8sk2b9jkms47vx5gp7mfs345grx9wq53plqq12"))
(patches
(search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))
(modules '((guix build utils)))))
@@ -1220,13 +1220,35 @@ application suites.")
;; This test, 'gtk:tools / validate', started failing for
;; unknown reasons after updating mesa to 23.3.1 and xorgproto
;; to 2023.2.
- ((" 'validate',") ""))
+ ((" 'validate',") "")
+ ;; XXX: These test failures come newly from 4.14.
+ ;; Not all of them are reported upstream yet, but the text nodes
+ ;; are mentioned in
+ ;; <https://gitlab.gnome.org/GNOME/gtk/-/issues/6647>.
+ (("'glyph-subpixel-position',") "")
+ (("'subpixel-positioning',") "")
+ (("'subpixel-positioning-hidpi-nogl-nocairo',") "")
+ (("'text.*\\.node',") "")
+ (("'text-mixed-color-colrv1',") ""))
(substitute* "testsuite/reftests/meson.build"
(("[ \t]*'label-wrap-justify.ui',") "")
;; The inscription-markup.ui fails due to /etc/machine-id
;; related warnings (see:
;; https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
- (("[ \t]*'inscription-markup.ui',") ""))))
+ (("[ \t]*'inscription-markup.ui',") ""))
+ ;; XXX: These failures appear specific to i686 – investigate them.
+ #$@(if (target-x86-32?)
+ #~((substitute* "testsuite/gsk/meson.build"
+ (("'empty-(fill|stroke)\\.node',") "")
+ (("'fill2?\\.node',") "")
+ (("'stroke\\.node',") "")
+ (("'fill-fractional-([a-z-]*)-nogl',") "")
+ (("\\[ 'path-special-cases' \\],") "")
+ (("\\[ '(path|curve)-special-cases' \\],") "")
+ (("\\[ 'path-private' \\],") ""))
+ (substitute* "testsuite/a11y/meson.build"
+ (("\\{ 'name': 'text(view)?' \\},") "")))
+ #~())))
(add-before 'build 'set-cache
(lambda _
(setenv "XDG_CACHE_HOME" (getcwd))))
@@ -1288,6 +1310,7 @@ application suites.")
python-toml
python-typogrify
sassc ;for building themes
+ shaderc
tzdata-for-tests
vala
xorg-server-for-tests))
@@ -1909,7 +1932,7 @@ tutorial.")
(package
(inherit gtkmm)
(name "gtkmm")
- (version "3.24.8")
+ (version "3.24.9")
(source
(origin
(method url-fetch)
@@ -1918,7 +1941,7 @@ tutorial.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1i4ql0j6id6g34w5nbhd7vjak7l3s50lqgdjaj2ranrfj9j0r56j"))))
+ (base32 "1kj4mla3z9kxhdby5w88nl744xkmq6xchf79m1kfa72p0kjbzm9h"))))
(propagated-inputs
`(("atkmm-2.28" ,atkmm-2.28)
("cairomm-1.14" ,cairomm-1.14)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13f54fcc5d..1416c3a36c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -899,6 +899,9 @@ tst_qt_cmake_create.cpp"
;; TODO: when core-updates is merged, check again.
"tst_selftests"
+ ;; The 'tst_qsqlthread' test sometimes fails.
+ "tst_qsqlthread"
+
;; The 'tst_qsystemsemaphore' test sometimes fails.
"tst_qsystemsemaphore"
;; The 'tst_moc' test fails with "'fi.exists()' returned FALSE".
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index cb368c1ab5..16c2b75510 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -306,7 +306,13 @@
(substitute* "tests/qtest/meson.build"
;; These tests fail to get the expected number of tests
;; on arm platforms.
- (("'arm-cpu-features',") ""))))
+ (("'arm-cpu-features',") "")
+ ;; This test is known to be flaky.
+ ;; See <https://gitlab.com/qemu-project/qemu/-/issues/2121>.
+ (("\\['ahci-test'\\]") "[]"))
+ ;; This test appears to be flaky as well, probably resulting
+ ;; from a race condition.
+ (delete-file "tests/qemu-iotests/tests/copy-before-write")))
#$@(if (target-riscv64?)
'((add-after 'unpack 'disable-some-tests
(lambda _
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index bf24a65e83..b71e7e3e29 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -127,13 +127,13 @@ engine that uses Wayland for graphics output.")
(define-public webkitgtk
(package
(name "webkitgtk")
- (version "2.42.5")
+ (version "2.44.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0jg7c7z572afywwrnvdj3m5agaviv0vkqmzznnzzv30byb0phhmn"))
+ (base32 "0qamkk9db8m6x4qv5y10lihc18yzgrgbn6ldqw00ckghn1ci8ns2"))
(snippet
#~(begin
(use-modules (guix build utils))
@@ -162,6 +162,7 @@ engine that uses Wayland for graphics output.")
;; tool to validate the good operation of
;; webkitgtk.
"-DENABLE_MINIBROWSER=ON"
+ "-DUSE_LIBBACKTRACE=OFF" ; XXX: circular dependency
;; The default lib installation prefix is lib64.
(string-append "-DLIB_INSTALL_DIR=" #$output "/lib")
;; XXX: WebKitGTK makes use of elogind's systemd-compatible
@@ -222,8 +223,8 @@ engine that uses Wayland for graphics output.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((doc (assoc-ref outputs "doc")))
(mkdir-p (string-append doc "/share"))
- (rename-file (string-append #$output "/share/gtk-doc")
- (string-append doc "/share/gtk-doc"))))))))
+ (rename-file (string-append #$output "/share/doc")
+ (string-append doc "/share/doc"))))))))
(native-inputs
(list bison
gettext-minimal
@@ -295,9 +296,8 @@ propagated by default) such as @code{gst-plugins-good} and
(arguments
(substitute-keyword-arguments (package-arguments webkitgtk)
((#:configure-flags flags)
- #~(cons* "-DENABLE_GTKDOC=ON"
- (delete "-DENABLE_INTROSPECTION=ON"
- (delete "-DUSE_GTK4=ON" #$flags))))))
+ #~(cons* "-DUSE_GTK4=OFF"
+ (delete "-DUSE_GTK4=ON" #$flags)))))
(propagated-inputs
(modify-inputs (package-propagated-inputs webkitgtk)
(replace "gtk" gtk+)))
@@ -322,13 +322,13 @@ propagated by default) such as @code{gst-plugins-good} and
(package
(inherit webkitgtk)
(name "wpewebkit")
- (version "2.40.5")
+ (version "2.44.1")
(source (origin
(inherit (package-source webkitgtk))
(uri (string-append "https://wpewebkit.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0cv74qy67a0hg8sba18wrjcmmwkj4z23wqnn5yqrh3n594q8srac"))))
+ (base32 "16y1gdz38d4b99b8zrvxy0nbrc70ih02ngi8090x7148rx7vz7rc"))))
(arguments
(substitute-keyword-arguments (package-arguments webkitgtk)
((#:configure-flags flags)