summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 09:59:22 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:17:03 +0100
commitbb79b85b1e024ee7d777bc9ca7b0ce4f07b8cf43 (patch)
tree815ccfcf80a7ad1e006af91a38154781b5ebb656
parente76a755ecec948676e40ab233cfcbe6cd307c19f (diff)
gnu: Add go-github-com-tidwall-gjson.
* gnu/packages/golang-xyz.scm (go-github-com-tidwall-gjson): New variable. Change-Id: If3345205e3cbc75c0a4aa51ea0e5566d6db9af71
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index bdad626368..e353b4af08 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3462,6 +3462,34 @@ well as a program to generate applications and command files.")
storage system.")
(license license:bsd-2)))
+(define-public go-github-com-tidwall-gjson
+ (package
+ (name "go-github-com-tidwall-gjson")
+ (version "1.17.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tidwall/gjson")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gcjzbs5in4kics39d2v3j2v9gvfxkdgp0bdgbfmcsa5arqgq7g5"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tidwall/gjson"))
+ (propagated-inputs
+ (list go-github-com-tidwall-match
+ go-github-com-tidwall-pretty))
+ (home-page "https://github.com/tidwall/gjson")
+ (synopsis "JSON parser for Golang")
+ (description
+ "This package provides a fast and simple way to get values from a JSON
+document. It has features such as one line retrieval, dot notation paths,
+iteration, and parsing JSON lines.")
+ (license license:expat)))
+
(define-public go-github-com-tidwall-match
(package
(name "go-github-com-tidwall-match")