summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraurtzy <aurtzy@gmail.com>2024-04-20 06:12:17 -0400
committerLudovic Courtès <ludo@gnu.org>2024-04-29 23:58:11 +0200
commitc1c367b55ed551f040154ac51330d3a6b1ff680d (patch)
treeafa8ca3460d6b8f8c53e5c4a2863df8e76beeb9b
parent5f03cfacd87f4ee1d978407cbd8bb266a25a7098 (diff)
gnu: Add libdecor.
* gnu/packages/freedesktop.scm (libdecor): New variable. Change-Id: Ic8d8886a55ae344fafbe16288a1180c89fa36af1 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/freedesktop.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 339297c087..081269ebaf 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -35,6 +35,8 @@
;;; Copyright © 2023 Alex Devaure <ajadevaure@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022 Samuel Culpepper <sculpepper@newstore.com>
+;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3234,3 +3236,34 @@ notifies the user using any notification daemon implementing
"Waypipe is a proxy for Wayland clients, with the aim of
supporting behavior like @samp{ssh -X}.")
(license license:expat)))
+
+(define-public libdecor
+ (package
+ (name "libdecor")
+ (version "0.2.2")
+ (source
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/libdecor/libdecor")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05rxchwzhnkm91kcr30mavizkp25wgjlhb6lcraa456pw7vgb04q"))))
+ (build-system meson-build-system)
+ (native-inputs (list cmake pkg-config))
+ (inputs (list cairo
+ dbus
+ egl-wayland
+ gtk+
+ libglvnd
+ libxkbcommon
+ pango
+ wayland
+ wayland-protocols))
+ (home-page "https://gitlab.freedesktop.org/libdecor/libdecor")
+ (synopsis "Client-side decorations library for Wayland clients")
+ (description "libdecor is a library that can help Wayland clients draw
+window decorations for them. It aims to provide multiple backends that
+implements the decoration drawing.")
+ (license license:expat)))