summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 13:18:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 13:18:56 +0200
commitc63164188fc893c9500c4c953c808d24c12b6894 (patch)
tree8bb4a24b699ae274a9105211bcc476f605c40f6e
parent97d9741f0be56d4a2860dc8620b56f859aefefee (diff)
gnu: Add python-googleapis-common-protos.
* gnu/packages/python-web.scm (python-googleapis-common-protos): New variable.
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 04cf3b5e3c..51e03ed56f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -88,6 +88,7 @@
#:use-module (gnu packages node)
#:use-module (gnu packages openstack)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages protobuf)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
@@ -6752,6 +6753,34 @@ Client Library for Python.")
of the CRC32C hashing algorithm.")
(license license:asl2.0)))
+(define-public python-googleapis-common-protos
+ (package
+ (name "python-googleapis-common-protos")
+ (version "1.56.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "googleapis-common-protos" version))
+ (sha256
+ (base32 "16x1pjc34mrj9w130j40r23ndpykhsqivvk5xfl63ss6qsfyapkb"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #false ;fails for unknown reasons
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs (list python-protobuf))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://github.com/googleapis/python-api-common-protos")
+ (synopsis "Common protobufs used in Google APIs")
+ (description "This package contains Python classes generated from the
+common protos in the @code{googleapis/api-common-protos} repository.")
+ (license license:asl2.0)))
+
(define-public python-w3lib
(package
(name "python-w3lib")