summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi via Guix-patches via <guix-patches@gnu.org>2024-04-17 10:34:44 +0100
committerChristopher Baines <mail@cbaines.net>2024-05-12 18:40:33 +0100
commitca571f4259df82500c687effcdb7d11904a52e6c (patch)
tree0c8e60108eda9e4103b452ca44acb7daa4f2b50e
parent0dac1307ccc9a04df49080f3c76b1018268d7d68 (diff)
gnu: Add python-vdf.
* gnu/packages/python-xyz.scm (python-vdf): New variable. Reviewed-by: Steve George <steve@futurile.net> Signed-off-by: Christopher Baines <mail@cbaines.net> Change-Id: Ie8a14292b9c9937d22f011ac078562e81abd6b36
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 70687883c2..557c6d5815 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6979,6 +6979,24 @@ text styles of documentation.")
"Pygments is a syntax highlighting package written in Python.")
(license license:bsd-2)))
+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "Work with Valve's VDF text format")
+ (description "This package provides @code{python-vdf}, a library for
+working with Valve's VDF text format.")
+ (license license:expat)))
+
(define-public python-pygments-github-lexers
(package
(name "python-pygments-github-lexers")