summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Higino <luishenriquegh2701@gmail.com>2024-06-01 05:06:31 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:17:02 +0100
commitca9fa4a88a4512a04fc3261e33e76eb509aa59eb (patch)
treeb1ee742909a04f43205a68f95ecad6f441ad391f
parent693037101bbacb8de03457bbd3b231e1897c7b37 (diff)
gnu: Add go-github-com-docopt-docopt-go.
* gnu/packages/golang-xyz.scm (go-github-com-docopt-docopt-go): New variable. Change-Id: I70ab7bce1a4ac13e1b63ecb72f5b7df0b8b94b69 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 71e8364f2b..6355178c29 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Luis Higino <luishenriquegh2701@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1186,6 +1187,33 @@ atimes for files.")
mtime,ctime and btime for files.")
(license license:expat)))
+(define-public go-github-com-docopt-docopt-go
+ (let ((commit "ee0de3bc6815ee19d4a46c7eb90f829db0e014b1")
+ (revision "0"))
+ (package
+ (name "go-github-com-docopt-docopt-go")
+ (version (git-version "0.6.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docopt/docopt.go")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hlra7rmi5pmd7d93rv56ahiy4qkgmq8a6mz0jpadvbi5qh8lq6j"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/docopt/docopt-go"))
+ (home-page "https://github.com/docopt/docopt.go")
+ (synopsis "Implementation of docopt in Golang")
+ (description
+ "This package provides command-line arguments parser based on written
+help message which may simplify crating CLI applications, it's Golang
+implementation of http://docopt.org/.")
+ (license license:expat))))
+
(define-public go-github-com-dustin-gojson
(package
(name "go-github-com-dustin-gojson")