summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-05-19 10:27:31 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-05-19 21:25:30 +0200
commitcf17cbbc1b16dd15c8ec2e637d240de7ae5c3a44 (patch)
tree7ae56ee06e69fb61ae1940ac42003a8d05edfe65
parenta0461f9fbd7e641f520eb543e967e59afdae31ea (diff)
gnu: Add emacs-terminal-here.
* gnu/packages/emacs-xyz.scm (emacs-terminal-here): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6482c9bfc3..ae81f4e395 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -485,6 +485,28 @@ repositories through the
server}. The main advantage compared to @code{vc-hg} is speed.")
(license license:gpl3+)))
+(define-public emacs-terminal-here
+ (package
+ (name "emacs-terminal-here")
+ (version "2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davidshepherd7/terminal-here")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1iv1c2mbvhn00ha46c6f98j9syc71xhjpk8m5wa5p32sk4wcc9f4"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/davidshepherd7/terminal-here")
+ (synopsis "Open external terminals from Emacs")
+ (description
+ "This package provides commands to open external terminal emulators from
+Emacs, whose initial working directories are determined in relation to the
+current buffer.")
+ (license license:gpl3+)))
+
(define-public emacs-hgignore-mode
;; From 2021-03-14.
;; No releases available.