summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-09 08:30:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:57 +0200
commitd224cf077b1d7629a478b4f0f9a8a3c85bb7ca51 (patch)
tree9e601510f1779a6b7bfde0fb1686f72b61168328
parenta2e8d5d62e76ac50791d1641edc0087677d13912 (diff)
gnu: Add texlive-xdvi.
* gnu/packages/tex.scm (texlive-xdvi): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c545f1c381..acc8b4b7ed 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12592,6 +12592,28 @@ reporting the number of the last page, as does @code{lastpage}). The counter
itself may be shipped out to the DVI file.")
(license license:lppl)))
+(define-public texlive-xdvi
+ (package
+ (name "texlive-xdvi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/xdvi.1"
+ "doc/man/man1/xdvi.man1.pdf" "dvips/xdvi/"
+ "xdvi/")
+ (base32
+ "17cqim8dwsbpcr7cd97fklsyaiwj7d7d0k2zkcv7981fcqinw5pn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xdvi")
+ (synopsis "DVI previewer for the X Window System")
+ (description
+ "Xdvi is the canonical DVI previewer for use on Unix and other X-windows
+based systems. The distribution has been integrated with that of Xdvik, so
+that it will build with web2c out of the box.")
+ ;; Xdvi is under MIT terms, whereas Xdvik extensions use BS2-2.
+ (license (list license:expat license:bsd-2))))
+
(define-public texlive-xetexconfig
(package
(name "texlive-xetexconfig")