summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 16:37:50 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:33 +0100
commitd7543abe35d68d5eba1e48bc95473e2351f10447 (patch)
tree98705bf1e76297d14ac09a6c1d5a56595cf2c9b3
parent4c51c895c0d2ccabaa11b7bd688a5a8751987266 (diff)
gnu: python-asdf: Sort alphabetically.
* gnu/packages/astronomy.scm (python-asdf): Sort alphabetically. Change-Id: I786ec48dda6d26c65ba7ff355d16411dc7d5a7e9
-rw-r--r--gnu/packages/astronomy.scm106
1 files changed, 53 insertions, 53 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 6cdd20b92f..908cd1cf5d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -556,6 +556,59 @@ Main features:
@end itemize")
(license license:expat)))
+(define-public python-asdf
+ (package
+ (name "python-asdf")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf" version))
+ (sha256
+ (base32 "1wj556g15gwp6ir5hg083l15sifdsf23giqkx0jbn4lgdwjffbgr"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-n" "auto" "-p" "no:legacypath")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pypojrect-toml
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; ImportError: Error importing plugin " no:legacypath": No
+ ;; module named ' no:legacypath'
+ ((".*:legacypath.*") "")
+ ;; TypeError: Configuration.__init__() got an unexpected
+ ;; keyword argument 'version_file'
+ (("version_file = \"asdf/_version.py\"") "")))))))
+ (native-inputs
+ (list python-fsspec
+ python-packaging
+ python-psutil
+ python-pytest
+ python-pytest-doctestplus
+ python-pytest-remotedata
+ python-pytest-xdist
+ python-setuptools-scm))
+ (propagated-inputs
+ (list python-asdf-standard
+ python-asdf-transform-schemas
+ python-attrs ;; for vendorized jsonschema
+ python-importlib-metadata
+ python-jmespath
+ python-lz4
+ python-numpy
+ python-pyyaml
+ python-semantic-version))
+ (home-page "https://github.com/asdf-format/asdf")
+ (synopsis "Python tools to handle ASDF files")
+ (description
+ "The Advanced Scientific Data Format (ASDF) is a next-generation
+interchange format for scientific data. This package contains the Python
+implementation of the ASDF Standard.")
+ (license license:bsd-3)))
+
(define-public python-astroml
(package
(name "python-astroml")
@@ -4492,59 +4545,6 @@ PYSYNPHOT, utilizing Astropy and covering the non-instrument specific portions
of the old packages.")
(license license:bsd-3)))
-(define-public python-asdf
- (package
- (name "python-asdf")
- (version "3.2.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "asdf" version))
- (sha256
- (base32 "1wj556g15gwp6ir5hg083l15sifdsf23giqkx0jbn4lgdwjffbgr"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- #~(list "-n" "auto" "-p" "no:legacypath")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-pypojrect-toml
- (lambda _
- (substitute* "pyproject.toml"
- ;; ImportError: Error importing plugin " no:legacypath": No
- ;; module named ' no:legacypath'
- ((".*:legacypath.*") "")
- ;; TypeError: Configuration.__init__() got an unexpected
- ;; keyword argument 'version_file'
- (("version_file = \"asdf/_version.py\"") "")))))))
- (native-inputs
- (list python-fsspec
- python-packaging
- python-psutil
- python-pytest
- python-pytest-doctestplus
- python-pytest-remotedata
- python-pytest-xdist
- python-setuptools-scm))
- (propagated-inputs
- (list python-asdf-standard
- python-asdf-transform-schemas
- python-attrs ;; for vendorized jsonschema
- python-importlib-metadata
- python-jmespath
- python-lz4
- python-numpy
- python-pyyaml
- python-semantic-version))
- (home-page "https://github.com/asdf-format/asdf")
- (synopsis "Python tools to handle ASDF files")
- (description
- "The Advanced Scientific Data Format (ASDF) is a next-generation
-interchange format for scientific data. This package contains the Python
-implementation of the ASDF Standard.")
- (license license:bsd-3)))
-
(define-public python-asdf-compression
;; TODO: No release, change to tag when it's ready.
(let ((commit "57cc7e76fb4163be3e99fb740b36b5ec5ae96e49")