summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-24 22:21:45 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-07 00:55:56 +0100
commitd78e91a469e56ede20d2d281b9dffda2ecdf9347 (patch)
treefe5d65903f832116a58957e6ae169a6a375f4e71
parent58c835a01feec5a89e7d98e99457311a0c70bd5c (diff)
gnu: Add go-github-com-pion-mdns-v2.
Redirect inheritance from go-github-com-pion-mdns v0.0.12 to keep consistency with the flow, older version is required for other packages. * gnu/packages/golang-web.scm (go-github-com-pion-mdns): Downgrade to 0.0.12. [arguments] <#:unpack-path>: Add it. (go-github-com-pion-mdns): New variable. Change-Id: Id580f9736fa92ed9ebb8597c1362eb945cff23e6
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 396f2aa772..058018f0aa 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1650,7 +1650,7 @@ in Golang.")
(define-public go-github-com-pion-mdns
(package
(name "go-github-com-pion-mdns")
- (version "2.0.7")
+ (version "0.0.12")
(source
(origin
(method git-fetch)
@@ -1659,7 +1659,7 @@ in Golang.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "03675hx82lx3c8akkxdbkch1z4dbq54r05jk6jgdyd7mrdh9k4lm"))))
+ (base32 "18nz0vddxik3q11mn4z65zvrfhspxv0xymxv9w3kgk2kszwq2byy"))))
(build-system go-build-system)
(arguments
(list
@@ -1668,6 +1668,7 @@ in Golang.")
;; <https://github.com/pion/.goassets/blob/master/.github/workflows/test.reusable.yml>.
#:tests? #f
#:go go-1.21
+ #:unpack-path "github.com/pion/mdns"
#:import-path "github.com/pion/mdns"))
(native-inputs
(list go-github-com-stretchr-testify))
@@ -1682,6 +1683,28 @@ in Golang.")
@url{https://github.com/pion, Pion}.")
(license license:expat)))
+(define-public go-github-com-pion-mdns-v2
+ (package
+ (inherit go-github-com-pion-mdns)
+ (name "go-github-com-pion-mdns-v2")
+ (version "2.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/mdns/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03675hx82lx3c8akkxdbkch1z4dbq54r05jk6jgdyd7mrdh9k4lm"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments
+ go-github-com-pion-mdns)
+ ((#:unpack-path flags ''())
+ "github.com/pion/mdns/v2")
+ ((#:import-path flags ''())
+ "github.com/pion/mdns/v2")))))
+
(define-public go-github-com-pion-rtp
(package
(name "go-github-com-pion-rtp")