summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:13:39 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:34 +0100
commitdac6f5e8e5bcc25038e3af97cc269676b57c8411 (patch)
treee7992435478bdeb1fb1a3e799fb70f368809697a
parenta58f40b8b65ef90c8af4a24f1173e898a0de4712 (diff)
gnu: erfa: Sort alphabetically.
* gnu/packages/astronomy.scm (erfa): Sort alphabetically. Change-Id: I3997cdbc90b94d6fda135ff274aeeceb9b58a9d5
-rw-r--r--gnu/packages/astronomy.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d1f98c27cd..b1f06edda8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -576,6 +576,31 @@ in FITS files.")
(license (license:non-copyleft "file://License.txt"
"See License.txt in the distribution."))))
+(define-public erfa
+ (package
+ (name "erfa")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/liberfa/erfa")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hxjbcvdlq4871r17fphbaf3bd8dsjagp1rdb3j8v6kr4f1dil9n"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list automake autoconf libtool pkg-config))
+ (home-page "https://github.com/liberfa/erfa")
+ (synopsis "Essential Routines for Fundamental Astronomy")
+ (description
+ "The @acronym{ERFA, Essential Routines for Fundamental Astronomy} C library
+contains key algorithms for astronomy, and is based on the @acronym{SOFA,
+Standards of Fundamental Astronomy} library published by the @acronym{IAU,
+International Astronomical Union}.")
+ (license license:bsd-3)))
+
(define-public python-aplpy
(package
(name "python-aplpy")
@@ -976,31 +1001,6 @@ zooming windows, star catalog access, cuts, star pick/FWHM, thumbnails, etc.")
(prepend python-pyqt)))
(synopsis "Qt5 image viewer build based on python-ginga library")))
-(define-public erfa
- (package
- (name "erfa")
- (version "2.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/liberfa/erfa")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1hxjbcvdlq4871r17fphbaf3bd8dsjagp1rdb3j8v6kr4f1dil9n"))))
- (build-system gnu-build-system)
- (native-inputs
- (list automake autoconf libtool pkg-config))
- (home-page "https://github.com/liberfa/erfa")
- (synopsis "Essential Routines for Fundamental Astronomy")
- (description
- "The @acronym{ERFA, Essential Routines for Fundamental Astronomy} C library
-contains key algorithms for astronomy, and is based on the @acronym{SOFA,
-Standards of Fundamental Astronomy} library published by the @acronym{IAU,
-International Astronomical Union}.")
- (license license:bsd-3)))
-
(define-public eye
(package
(name "eye")