summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-04-30 11:03:10 +0200
committerLudovic Courtès <ludo@gnu.org>2024-04-30 11:06:02 +0200
commitdf3d30819e650a490ef39dd6692740bb13263c75 (patch)
tree9244a7bdd1eb41a9af8b5b36d1a330b0b46ab882
parentddf3759645ba76ef532658a257ae74fe0b1788b5 (diff)
gnu: guile-lzlib: Switch to ‘url-fetch’.
Fixes <https://issues.guix.gnu.org/70659>. Fixes a regression introduced in 7cef6b7ba555a9dfaf6d09cb7e112b0df77d5141, which would create a circular dependency on systems lacking “builtin:git-download”. * gnu/packages/guile.scm (guile-lzlib)[source]: Switch to ‘git-fetch’. Reported-by: Peacememories <peacememories@posteo.net> Change-Id: Iad684564d0dc18f0a7a76e1c4c6464ba4f39f2e8
-rw-r--r--gnu/packages/guile.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 8c634c26e3..58a044fa9d 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -926,12 +926,17 @@ Guile's foreign function interface.")
(home-page "https://notabug.org/guile-lzlib/guile-lzlib")
(source
(origin
- (method git-fetch)
- (uri (git-reference (url home-page) (commit version)))
- (file-name (git-file-name name version))
+ ;; Note: Until "builtin:git-download" can be taken for granted, this
+ ;; must be 'url-fetch', not 'git-fetch', to avoid a circular dependency
+ ;; with the 'git-fetch' derivation on systems that lack
+ ;; "builtin:git-download".
+ (method url-fetch)
+ (uri (string-append home-page "/archive/" version ".tar.gz"))
+ ;; content nar-sha256: 19870njb3q5h6zy239gvra92ji077c6s8xm0hgcn42z74q5wqnk6
+ (file-name (string-append "guile-lzlib-" version ".tar.gz"))
(sha256
(base32
- "19870njb3q5h6zy239gvra92ji077c6s8xm0hgcn42z74q5wqnk6"))))
+ "1whgmwkr1v8m63p4aaqn8blwl9vcrswwhbfv4bm0aghl5a6rryd7"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags