summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:35:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:42:53 +0200
commitdfe2fb8da73f7489eaa8c3286cb047b5e150313c (patch)
treef45bc6e199609d1de8526c4734a46a6da8f91cd3
parenta64a98444046668665f81e43f8d661898e44c7d9 (diff)
gnu: Add texlive-collection-langarabic.
* gnu/packages/tex.scm (texlive-collection-langarabic): New variable.
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1eb164ffac..2ccc2eb706 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -41013,6 +41013,48 @@ includes the Aleph engine and related Omega formats and packages, and the
HiTeX engine and related.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-collection-langarabic
+ (package
+ (name "texlive-collection-langarabic")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-alkalami
+ texlive-alpha-persian
+ texlive-amiri
+ texlive-arabi
+ texlive-arabi-add
+ texlive-arabic-book
+ texlive-arabluatex
+ texlive-arabtex
+ texlive-bidi
+ texlive-bidihl
+ texlive-collection-basic
+ texlive-dad
+ texlive-ghab
+ texlive-hvarabic
+ texlive-hyphen-complete
+ texlive-imsproc
+ texlive-kurdishlipsum
+ texlive-lshort-persian
+ texlive-luabidi
+ texlive-na-box
+ texlive-persian-bib
+ texlive-quran
+ texlive-sexam
+ texlive-simurgh
+ texlive-texnegar
+ texlive-tram
+ texlive-xepersian
+ texlive-xepersian-hm
+ texlive-xindy-persian))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "Support for Arabic and Persian")
+ (description "This collection provides support for Arabic and Persian.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-collection-langcjk
(package
(name "texlive-collection-langcjk")